Open URL with Firefox – "#" translates to "%23"

Dear KM-Maestros,

I would like to open Firefox’s preferences not showing the general tab but the privacy tab.
Using “about:preferences#privacy” in the adress field opens the privacy tab.

But when I try the action “Open URL” with Firefox using the string above the URL in the browser’s adress field changes to “about:preferences%23privacy”.

It doesn’t happen

Do you know how to fix this? Or maybe a workaround?

Thanks in advance

OS X Yosemite
Firefox 55.0.3 (64-Bit)

What happens if you URL-encode the URL?

Or URL-decode it?

1 Like

like this?

=> nothing happens …

And decode?

Not sure if it is related, but see here.

This works for me:


Yes, Tom, works for me too … thanks a lot to both of you, Martin & Tom!

The Open URL action use the NSURL URLWithString API to encode the URL, which apparently considers “about:preferences#privacy” to be properly encoded as “about:preferences%23privacy”.

This could be considered either a bug with URLWithString or a bug with FireFox. Either way, there is not much I can do about it in Keyboard Maestro, so I suggest the AppleScript solution is a good workaround.

yes, of course – thanks for your post, Peter!

Thank you!