Prevent keystoke action from typing both keys?

I bought a USB keypad/numberpad that I want to use for macros separately from my main keyboard.

For this example, I want the keypad's #7 to type the letter "q". It works, but when I press #7, it actually types "7q". Is there a way to tell it to NOT type the #7?

When I tried setting this up as a Hotkey instead, it seems to work fine, but also applies the macro to my main keyboard, and I only want it to be accessible by the separate keypad.

Have you tried USB Device Key trigger?

You might also want to investigate using Karabiner-Elements.