Problem with Clipboard History Switcher

I am a long time novice user, and I love KM!
I use the Clipboard History Switcher and Activate Clipboard History Switcher about 1000 times a day.
But since the last update (I think) my trigger is not working to pull up the Switcher window and often the clipboard is not capturing the latest stuff I copy.
I literally have to reboot the computer to correct the issue.
Is anyone else having the problem...and any suggested fixes?
Can I roll back to the previous version?
This issue is killing me...I use the clipboard and switcher all day long and really depend on it.
Thanks, Gregg

Start by trying the Assistance window (Help ➤ Assistance) and clicking the Something expected is not happening and follow the instructions there and see what you can learn.

The macro you are using is the Activate Clipboard History Switcher macro in the Switcher Group.

Thanks for guiding me to this tool, Peter, it's very smart.

Its been waiting for macro to trigger for about 5 minutes.

See screen shot.

Thanks for any additional help you can offer.

I thought the problem was the new version, but after several days it starting happening again even though I rolled back to a previous version (8.2.1).


Ahhh. Somehow I went to rolled back version to new version. So everything worked fine in 8.1.1 and stopped working when I guess auto upgraded to 8.2.1. I guess solution is to stop auto upgrades for awhile.



Sorry, last post (I hope).

Is it possible to prevent auto-updates?

I don't see it in preferences...

Thanks, Gregg

Yes, I get the same exact popup window, that says:
"Waiting for the Macro to Trigger..."

I find this confusing.

What it means is:
"Now, take some action that should trigger this macro, including activating another app".

@peternlewis, IMO the "Assistance" popup needs to be revised, something like this:

You now need to trigger the macro manually by whatever means you normally use, and Keyboard Maestro will show you when the macro is triggered.

Assuming the macro is then triggered, then you know you can look at the actions and see why they are not doing anything.

It is highly unlikely that rolling back to 8.1.1 will improve anything.

You can configure notifications to only happen when you launch the editor in the preferences.

I was just having a problem with the Switcher taking ~4 sec to appear -- very, very unusual in my experience. I fixed it by running this macro:


I'm not sure where I got the number "212", since the Switcher scrolls only to 199. But 212 popped up in my brain, so I went with it. All history was cleared.

Fixed in Keyboard Maestro 8.2.2.

1 Like