Rogue 'set action delay' action causing misery

I've seen this discussed before, but I am still very stuck.

For a week or so now, my action delay in all my macros seems to be set to 1 second, which is a miserable eternity...

I have another macro with the action 'set action delay', set to .1 seconds, "permanently" and this seems to resolve.

However (and I'm not sure the cadence of this) the issue always returns, often in the same day.



Basically, you should pretty much never use the Set Action Delay action to set the action delay permanently.

It should only ever be used to set the action delay for the specific macro.

I suggest go through your macros and find any use of this action and ensure they are only configured for this macro and then you create the Set Action Delete action, set it to reset and permanently and then select each option and Try it once to clear them all.

You can also run the Terminal command:

defaults read com.stairways.keyboardmaestro.engine | grep Delay

which will give you likely culprits.


Turns out I was mistaken. I had been using wait for front browser to finish loading, as I had switched to Edge. Turns out Edge is not supported by that action...

1 Like

It should be. The most likely issue would be if it does not have a Stop menu item that is disabled when the page finishes loading, as that is part of the test the action performs.