[SOLVED] Can't Click on a Button in Chrome Using JavaScript

Hi there! Thanks for the taking the time to help me. I'm trying to use JavaScript in Chrome to click on a button to grant BOX access to my stuff. I tried 6 methods and can't get it to work :confused: Would you be able to help me out, please?

Element: button id="consent_accept_button" name="consent_accept" class="btn btn-primary mhn login_submit fw lh32 ram" title="Grant access to Box" value="Grant access to Box" type="submit">Grant access to Box Granting access to Box...

XPath: //*[@id="consent_accept_button"]

Screen Shot 2022-10-08 at 10.47.53 AM

Screen Shot 2022-10-08 at 11.16.53 AM

I think nothing works on my side for KM + Chrome, I can't even use Click Google Chrome Link...Trying to click on NEWS on https://www.bmi.com/, Xpath doesn't work and there is no token showing up :confused:

Posting the solution I found here to help others. It turns out that you need to allow JavaScript events from Apple Events in Chrome/View/Developer, then I used a macro from JMichaelTX (THANKS!!!) to click on something via XPath

[WEB] Click on Link Using XPath [Example].kmmacros (11.9 KB)