Specific Macro Not Triggering Off HyperKey

Hello all,

The strangest thing has started happening of late. A specific macro doesn’t seem to be recognising the use of my Capslock as a hyperkey. The odd thing is, all of my other macros that also use the hyperkey, continue to work.

So each time I try to use this macro, I must remember to press all the keys individually (like an animal :sunglasses: ), or it doesn’t work.

I had thought the issue might have arisen with my switching from Karabiner to BTT, to regulate/implement the hyperkey. So I then purchased a dedicated hyperkey app — and it is still doing the same. But as mentioned, all the other macros work.

By way of context, I use an Ultimate Hacking Keyboard v1, plugged in via USB. I trigger the macros off this keyboard.

Any suggestions about where to start looking for a fix?

Hi Cassady,
not much of a help, but I can at least report, that I'm also using a Ultimate Hacking Keyboard (v1) and all of my hyperkey shortcuts just work as expected (I'm realizing the hyperkey with Karabiner).

It sounds like your specific shortcut may be occupied by another macro or by another app that offers global shortcuts. So your shortcut is bound to something other than that macro? Have you tried to give your macro a different hyperkey-shortcut. Does this change anything?

@medienmeister Love my UHK! [And side-note: Are you looking at purchasing any of the modules, that have finally been released?]

Thanks for the suggestion! That had me go back, and pay attention to the trigger designation inside the Macro.
I notice now that when I try and replace the trigger, by typing "hyperkey/capslock+Y", only "Y" is captured... And when I then hit all of them as a combination+Y, it works/is captured as expected.
This also happens with any other hyperkey+"key" combination.
So, obviously, something is interfering with the hyperkey being "seen" inside KM...

Will keep digging.

… ok, this seems like a headscratcher, as other macros with the hyperkey work as expected. Maybe this is a case for support.

Just an addition to Karabiner. It comes with a little utility named "Event Viewer" that logs the keyboard events that the machine actually receives when you hit a key. I find this helpful when trying to dissolve "forgotten key sequences" myself.

[and regarding UHK modules: I ordered one right from the start. I have been waiting for it over three years now and I must say, I don't bother any more. Time has healed my enthusiasm and from hindsight: I wouldn't recommend my former self the modules. – The keyboard itself is superb and incredible versatile, a dream for every Keyboard Maestro :slight_smile: ]

Many thanks. Think I might just go back to Karabiner, and use the "Event viewer" app again. I had forgotten about the latter, having used it before. That will helpfully help to narrow down the issue.

[On the modules: My understanding is that they are working through processing the back-orders of the modules, and Twitter has users finally getting them in hand – so far, very positive feedback! So if you have an order with them, might be worthwhile checking things on the website, since you might be (finally) getting it! Hope they come through!]

Ok – just to close this loop.

I have reverted back to Karabiner Elements.
Not sure why, but neither BTT, nor the little Hyperkey app, seem to play nicely with whatever KM is doing.
With Karabiner now controlling the capslock to hyperkey, all is now working as it should inside KM – which correctly picks up the key combinations being triggered.

:man_shrugging:t3:

1 Like

That is very good to know. I was just about to buy BTT just for the hyperkey feature, but it sounds like Karabiner is the better way to go.

@peternlewis, can you please confirm that KM works better with Karabiner, to directly use the Karabiner key remaps, whereas with other tools like BTT it does not.

Unfortunately, no. I do not use either of them. Whether they work with Keyboard Maestro or not is up to them, especially for hot keys which is a straight system API, so its handling of hot keys is outside Keyboard Maestro’s control.

@JMichaelTX I would be very surprised if my issue lay with BTT, or Hyperkey. Pretty much convinced that something unique to my system is causing this.

David Sparks (MacSparky) and plenty of others over at the MPU forums are happily using BTT along with KM – so really do not think my problem should give you cause for concern. If not mistaken, BTT offers a trial – and it really is an excellent piece of software, that I use countless times a day.

[EDIT:] Ok, in the interests of transparency, seems I am not the only one with issues around BTT's implementation of the hyperkey. It was not my intention of casting aspersions on BTT – as noted, plenty of others seem to be using it just fine. YMMV!

I am having the same issue with BTT. I also tried Ryan Hanson's Hyperkey app; I can't use Karabiner because it causes an unrelated problem on my system.

As in your case, a hyperkey combination trigger works fine with other macros. The macro I am having trouble with starts with a Copy action: when the macro is triggered via a hyperkey combination this action times out. It works fine when the macro is triggered via the status menu.

Perhaps a Copy action was used in your macro as well? In any event, to work around it, I use the Select or Show a Menu Item action to select the Edit>Copy menu item in the current application. Now the hyperkey combination works fine.

(Because I don't want the copied item on my system clipboard—my original idea was to copy it to a named clipboard, an action which also timed out when the macro was triggered with a hyperkey combination—I use the Delete Past Clipboard option at the end of my macro.)

Just to add my experience:
I used the Hyperkey.app for months without problems (becasue Karabiner Elements wasn't yet ready for Apple Silicon or something, I forgot).
Then, yesterday, a new macro for sequential pasting that I triggered by hot key [hyperkey] + V, did not work well.

The macro pastes the first line of text in a variable via regular expression and stores the rest back to the same variable. Debugging (especially screen recording the debugging window) showed, that the regex search part was executed several times at each keypress. The Semaphore Lock wasn't able to prevent it.

The macro worked as intended when used with a hot key trigger that didn't use the hyperkey. So I assumed this was the culprit. I tried BetterTouchTool, but it had the same problem. After finding this thread, I installed Karabiner Elements again (which is now ready vor Apple Silicon) and it works. These tools seem to do the same thing in different ways of which only Karabiner Elements always plays nice with Keyboard Maestro.