-
“Reset variables” at the beginning is good practice.
Better practice: make it a sub-macro. -
“Repeat Actions” is another good candidate to be a sub-macro.
Make it better by passing a variable for the number of times to repeat the loop. -
Lots of “Search and Replace” actions.
Instead, have one sub-macro and pass a variable for what to replace. -
On a flow chart, the code above would look like a long and winding road; difficult to maintain.
Better practice: use a tree structure with lots of thin branches.
Or hub-and-spoke structures with small, controlling macros at the center. -
To improve macro names change to noun first, verb after.
Instead of “Fix Quiz Options for Core Quizzes” …
make it, “Quiz Options: Fix Core Quizzes”.
That way every macro acting on “Quiz Options” will appear together in the macro list.
For naming macros, nouns (targets of action) are almost always more important than verbs (what the action does). -
Old programmers’ “Rule of Thumb” to make future maintenance easier:
One action : One comment
Being willing to expose your work and to learn, on a public forum like this, takes courage.
My compliments on yours.