Trigger not firing unless first "run" from Maestro

Yes... I tried that. Doesn't work... can't find the button, it says. Your program is obviously amazing, but way too complicated for an "ordinary person".... best for computer nerds, I'd say. QuicKeys was much more intuitive and easier to learn. Unfortunately, it doesn't work on Catalina. Since you offer no solution, I shall just have to continue as I have, using "record" EVERY TIME I need to use this function. I'll try your "How Do..." but really expect no solution.

If you mean KM, it’s not my program. I’m just a user like you and I don’t think I’m a nerd :crazy_face:

Have you already checked the basic documentation? You find most of it in KM’s Help menu:

In particular:

  • Welcome to Keyboard Maestro
  • Keyboard Maestro Quick Start

And the Keyboard Maestro Wiki (also accessible via the Help menu) is always a good reference and the first location where you should look up things that aren’t clear.


@Koltrasten, welcome to Keyboard Maestro (KM) and its Forum.
KM is one of the best Mac automation tools available, its Forum is one of the best and friendliest forums on the Internet. Whenever you reach a tough stumbling block trying to use KM, please feel free to post your question/problem here for help.

You will also find this helpful:
Tip: How Do I Get The Best Answer in the Shortest Time?

Actually, Keyboard Maestro (KM) is designed for those with no programming skills (but is also very useful to us programmers).

Like any language, or Mac app, you have to spend some time to learn how to use it.
With KM, a little bit of learning goes a long way.

The design of KM is much different from, and IMO much better than, QuicKeys.
You may find this KM Wiki article helpful: Transition From QuicKeys

As you have a little bit of time try to work your way though this:

Getting Started with Keyboard Maestro

For more help, see Getting Started with Keyboard Maestro and the Forum .


Sorry if I seem "negative", but I'm more likely frustrated. I may be 84 years old, but I speak four languages. The problem is, I don't know the nerd language that KM instructions are written in, so it is a hard task even understanding what is meant. It is like reading French, which I have long forgotten. It is as I have said, that such instructions are written for people who already know what to do, more or less, anyway. I tried, for example, to "post" my Macro, but I obviously do not understand those instructions and it didn't work. I COULD send a screen dump of the Amadeus app showing what I am trying to do, but I see no way to do THAT here in this Forum, either. But, it seems that I can reply to your e-mails, so I will send that information using e-mail. OK, here is what I do and am trying to do, step by step. I have Amadeus already running. I then hit a key to trigger Amadeus to open a new window called "Repair Centre". (That works because I found, by trial and error, how to access the list of actions for Amadeus by clicking "with two fingers" on the "No Action" box. I must have missed THAT instruction, somewhere.) Anyway, so that works. Then I want hot keys that activate the buttons "Find Next" and then "Repair". I have found no way to do that other than using "Record", although using record was clearly not the way to go, Tom? And it probably isn't since the two only work after I have "played around" with them in KM a while... then, after starting everything up again, they don't work at all. So, what I want to know is when I have a Macro with a hot keys ready, how do I trigger the buttons in the window that is already open in Amadeus? Simple, but not.... I will send that screen dump via e-mail ASAP. (PS. Even QuicKeys evolved into a somewhat nerdy program since I first used it back in the early 1990s, so at the end, I was using maybe only 10%. For KM, I used maybe 1%, like writing text -- THAT works!)

Hello people,

Here is that window I wrote about....

    The window is open and I want hot keys that

will click "Repair" and "Find Next"..... What do I do?




PS. Aha... if I send by e-mail, the graphics end up here.... cool!

OK, try this:

Click Repair and Find Next <B9AA 200224T150901>.kmmacros (4.8 KB)

The macro will work only if

  • Amadeus is the frontmost app
  • the Repair Centre window is the frontmost window of Amadeus

Usually when you invoke Repair Centre from the menu, the Repair Centre window starts out as frontmost window, but if you do semthing in-between, this may not be the case.

Here the graphical difference of the window when it is frontmost…

…and not frontmost:

So, if it is not frontmost you’ll have to make it frontmost by clicking the title bar of the Repair Centre window. (Clicking anywhere in the window doesn’t work!)

I tried to prepend some actions to make sure the Repair Centre window is frontmost, but this didn’t work. It is probably not a standard window.


  1. Make sure macro and macro group are enabled.
  2. Set the hotkey trigger to your needs.
  3. Open Amadeus on a track and invoke the Repair centre window from the menu.
  4. Run the macro via hotkey (not from within KM!)

Some notes:

  • I think the actions are self-explanatory. If not, let me know.
  • Each run of the macro clicks Repair, then Find Next. It does not automatically repeat this until everything is repaired. For the next crack you have to press the macro hotkey again. (I think this is what you demanded.)
  • The macro starts with a check if Repair is enabled and clicks Find Next if Repair is not enabled, because when the window is invoked, the first button to click seems to be always Find Next, then Repair. From the next run on, the macro should click Repair first, then Find Next.
  • The pause after Repair is just a safety measure. It seems to repair as well when we click Find Next immediately, but it may be different with very long “cracks”, I don’t know.
    • Try with the Pause action disabled, and if it works fine, then leave it disabled.
    • I cannot use a Wait until Find Next button is Enabled action, because it is always enabled.

I do not recommend to communicate via email, because (last time I tried it) you won’t get emails when a post has been edited by its author. This means, you are potentially replying to an outdated post.

Email is fine for notifications, or quick replies, but not so much for a complex conversation where details matter.

You can post a screenshot (graphics) just as easily via web browser: Just drag (with the mouse) the graphics file from the Finder into the editor window of the forum.

1 Like

Hi Tom,
Thanks for all the work. I have downloaded that file shown in blue ... correctly, I hope... using "Import Macros Safely...". However, I cannot get it to do anything. Nada! I'll "play" around with it for a while and get back to you, later. Maybe I will learn something. :wink:

In the meantime I have added some info above (namely “Instructions”) and made the Notes more clear. Please check if this helps.

Hmmmm.... no joy, so far. Actually, to make it even simpler, if I had one hot-key trigger that would click on/press "Find Next" ---- and another different hot-key that would click on/press "Repair". That way all I would need to do is to press these two keys alternatively, one after the other. I could use the Swedish letters "ö" for Repair and "ä" for Find Next, since I would not normally need them once Amadeus is running. I did THAT successfully with the recorded triggers, although not for long, as I mentioned. I could see, for example, that the "click" missed the buttons, if the Repair Centre window moved for some reason. Sometimes they seem to be off even if I hadn't moved it. What do you think?

Please let me know what is not working.

Macro and macro group are enabled, right? (See links in post above, in “Instructions”.)

It may work with letter keys, but don’t use them for the moment. You are actually complicating things with that, because you introduce an additional potential error source. Stay with the usual hotkey triggers like F1, F2, ⌘F1, ⌃⌥⌘P, etc. Do not use normal letter keys without modifier keys as trigger, or even Typed String triggers.

You can still experiment with exotic triggers once the macro works.

Previously, I used a modifier key, but my recorded macros worked even without that — when they worked. Everything has that "blue check mark" as far as I can see. As to what is not working, the answer is that absolutely nothing happens, no warnings, no nothing?

News update! It now started to work, and just like with the others. When I changed the hot-key to something else and then changed it back to F1, bingo! We'll see if this keeps on working... it will save me a lot of tired finger muscles.... LOL

I just ran through an LP with no problems. I do not understand your macros, but am thankful that I can now avoid the monotonous, repetitive exertions. Thanks again for the help!

1 Like

Do you mean the macro I posted above works now (or are you speaking of some “recorded” macro)?

Almost smells like one of those permission issues. Have you seen this post:

TIP: Resolving Catalina (and Mojave) Accessibility and Security Permissions Issues

Make sure to follow the tips there, if such problems re-occur.

And, make sure to only use trigger hotkeys that are not already mapped to something somewhere else.
“Somewhere else” could be…

  • the application itself (Amadeus)
  • the system (System Preferences > Keyboard > Shortcuts)
  • other KM macros
  • similar apps like KM, that allow key mapping

I caught the "already mapped" problem early on. "Permissions", huh? I'll look into that. Keep your fingers crossed.

Good morning! My hot-key problem is still around, at least now as regards Adobe Photo Elements 2020. After spending a whole day of trial and error, yesterday, I finally put together two Macros that work (whoopee!), but only if I hit the "try" button within KM itself —
No hot-key variation that I have tried does anything. One possible problem is that Adobe uses quite a few itself, but even if I try some utterly weird combination, nothing happens. I am running OSX Catalina, any ideas out there?

I took the libarty and marked this post as “Solution” for your Amadeus issue, because —if I understood correctly— you said that it worked here. (Click the blue text to see the posts.)

If this is not the case, then please tell me, and I will uncheck the “Solution” checkbox again.

Point of the “Solution” checkbox is to indicate to other readers that the thread has come to a solution.

For your new post, it would probably be a good idea to make a new topic with that, because it is not very related to the previous issue. (Different program, different issues.)

Hi Everett,

It's allways frustrating when you do not get something to work, which you want to work so badly.

Maybe, maybe this helps:
What I noticed is that your hot-key problem picture (about Adobe Photoshop - Rotate Image RIGHT)
doesn't show a assigned hot-key!!
to assign a hot key:

  1. Click with you mouse pointer just once on the rectangle with the text 'Click'
  2. Then press the key on the keyboard (including modifiers, like command, shift or control) which you want the hot-key-trigger to be assigned to

Then your hot-key is set

Hope this works for you,
All the best

Thanks for your info, but THAT was just in that image.... I have tried every possible hotkey combination possible. Spent way more time already than I would ever save, so I have given up on BM -- at least as regards Adobe.