Variable not resolved in export ("Save as") window... display text works

I initialize a variable, ProjectName, in the beginning of a macro. I'm in a situation, where I'm going to export the project to a new file. Standard stuff in Logic.

The issue is that while I can see the variable in the debugger it doesn't resolve in a type text action. I first thought it was related to variable scope, but it seems not to be the case. I tried to load the variable into a local variable, and that works.

Next attempt was to display a text at the same level (group) as the Insert text by typing action. Text is displayed as expected, but the variable is not resolved when typed in the dialog. I added some Wait statements... because, well, voodoo. Please refer to images of Export dialog, debugger state and actions.

I have done this successfully already in a different macro (I'm a KB beginner), but here, in this dialog, it just doesn't seem to resolve.

KB: 10.2

It may be that one of the options in the action's gear menu is not set correctly.


Check that the action has Process Text Normally set as shown.


Thanks for that, not sure how it had gotten that state, but now it works as expected! :+1:t2:

1 Like