Why Do I Get an Error Boop for This

Here's a macro that I've used multiple times with not problems:

Today, when I press the hotkey in PSE, I get an error boop. If I select "Try" in KM, it works fine.

Can anyone tell me why it isn't working?


I'm finding that if I make it a global macro, it works okay.

Hey Al,

Chances are you've disabled the macro itself accidentally.

Select your macro in the Keyboard Maestro Editor.

Select “Assistance” from the “Help” menu.

Select “Something expected is not happening...”

Go through the motions and see if anything pops.

If NOT then report back, and we'll look deeper.


I don't think that's the problem. I get the feeling that PSE is not letting the keypress in.

With this testing macro, I cannot get it to trigger in PSE (no boop now, just doesn't work).

If I make it global, it works fine.
If I make it require the LibreOffice is running, it works fine (in LibreOffice).

Keyboard Maestro 8.2.4 “Testing Activation in PSE” Macro

Testing Activation in PSE.kmmacros (2.8 KB)

It sounds like the macro group is not active as @ccstone suggested.

If the macro is disabled, then the Control-V keystroke would go to PSE which would probably beep.

Christ solved it for me. Oops, I mean "Chris." :grinning:

I had somehow gotten a condition in there for the Photoshop macros:

I deleted that, and now it works.

Many thanks for the help.