Zabobon's Dynamic Workspaces v4.04

Version 3.08 adds a "Help" button with detailed instructions.

Trying to strike a balance between keeping the interface as simple as possible whilst still providing instructions on how to actually use these Macros.

Apart from bug fixes I think I'm done now.

1 Like

This was a regional language issue, that meant the Macro didn't work correctly on Macs set to a System Language other than English. It was because I had used a Menu Item to pause the Macro until Apps were fully open. I'd used "About Safari" "About Google Chrome" etc as the menu item for Keyboard Maestro to look for. But for Macs set to a different language "About" is written as something else. Anyway, fixed in the latest version 3.09 and should run correctly even if the Mac is not set to English.

I can confirm this update finally works for me. Great work!

1 Like

I'm new to KM, and running into a problem getting this dynamic workspace macro to work properly. KM 9.2, Big Sur. I've imported the ZDW macro, and I see it in the list of macros. And if I manually click on 'run', the macro will run. However, what is NOT working is launching it via hotkey. Nothing happens. I even assigned a new hotkey (i.e. command 1), and nothing.

I have successfully created another macro in KM and its hotkey works just fine. So I'm a bit baffled here as to why the default (and custom) hotkeys for ZDW don't run the macros.

Could be a stupid new user issue and probably is....but I can't figure it out. Any help would be greatly appreciated.

Hi @Wolf359SD

When you import a downloaded Macro or Group the Group will come in disabled (for safety reasons). You have to enable the Macro Group for any of its Macros to be triggered by hot keys.

Here are instructions:

https://wiki.keyboardmaestro.com/Macro_Activation

Hello there,

Thanks for the v4.04. I like the new addition "Minimize Other Finder Windows". I'm getting Stream Deck today, would love to see your macros working with Stream Deck. Probably I'll be in touch for the next couple of days :no_mouth:

Have a great day!