6 macros have stopped working after updating to Sierra

I’ve noticed that at least 6 of my macros have stopped working after updating to macOS Sierra. Is there a general solution to this problem?

I don’t think there’s a general solution, assuming you’ve downloaded the latest version of KM.

Post some details, and perhaps we can help.

Many macros have stopped working after updating to Sierra. Attached is a screenshot of one of them.

Can you please be more specific in what you mean by “stopped working”?

  1. Macro does not execute at all
  2. Executes, but stops/fails with Action [identify the action]
  3. Fails with error message (post it)
  4. Other, be specific

Have you tried running the Macro in debug mode?

After lots of fiddling, several macros that had stopped stopped working are now working again. Not sure why they had stopped working or how I got them working again.

However, the attached macro is still not working. Having ran the debugger, it appears that it stops at the very first action, but doesn't give an error message. This macro was executing fine before updating to Sierra. Any ideas why it stops at the first action?

Hey Ross,

Methinks there are elements of this you’re not showing.

-Chris

Let me know what you need to see and I’ll post them

If you are debugging, and you have it set to pause the macro, then it would stop there until you tell it to step onwards.

Other than that, there is no way for the macro you showed to stops at or after the first action (Set Variable to Text).

Whatever the problem you are having, that macro above will behave identically in Sierra or El Capitan, so the problem is elsewhere.