A Macro to fix a Midi Problem


I've just found out that the Midi Keyboard i use has a hardware fault. With the Midi Drum Pads

But i was wondering if it was possible to create a script to workaround the problem.

If you look at the three highlighted notes on the midi monitor.

The 1st note is what i wanted then it switches off.

But at exactly the same time it's switched off, it is switched back on again, an its much louder.

It makes trying to use my Drum pads very difficult as this happens regularly.

I was wondering if it was possible to only allow another midi note to play after a few milliseconds or a few tengths of a second until another midi note is allowed to play, hopefully stopping the hardware issue.

Or maybe there is a better way of solving the issue.

Many Thanks

Keyboard Maestro can only detect MIDI notes, it cannot change or affect them.

You could maybe have it detect notes, and then choose some but not all to send, and use that new output as the source to actually play but I very much doubt you'd get a good result out of that (Keyboard Maestro is not a Real Time Operating System and simply would not be able to react quick enough to make it work well).

Thank you Peter,

I thought it would be a stretch for keyboard maestro to fix this difficult issue.

I Appreciate you explaining why it can't be done.

I recieved a Javascript code to place in Logic Pro to stop it but it didn't work it performed exactly how you explained.

Hello @keithrego21,

I'd probably try to fix the hardware issue. But maybe a specific kind of filter might help.

I'm using a small but very powerful tool for special MIDI tasks on Mac OS. It's called MIDIPipe. It's free although I donated because I'm using it more or less on a daily basis.

If your second note on the C3 is always on a higher velocity value it might be possible to use MIDIPipe to convert this Note On command into a Note Off command. I attach two screenshots of the settings. Maybe worth a try.


Interesting, i will give this a try and let you know how i get on.

Thanks a lot!!