Accessibility Issues in El Capitan

Upon opening Keyboard Maestro, I immediately get prompted for two things.

1.) Accessibility Access is Required

I’ve opened system preferences, unlocked the settings with my password, and checked the keyboard maestro box. Nothing happens; it still prompts me immediately after when I try and do something.

2.) Secure Input is Enabled

It suggests that 1Password or LastPass might be the cause of this. I use neither of those. I thought Karabiner may have been the issue, but it doesn’t seem to be.

I couldn’t find anything on this forum about this, and the KM homepage tells me that El Capitan should be working fine. Figured I’d post it here.


That should work. If not, try:

  1. Restarting the KM Engine (from KM Editor, File > Quit Engine, then Start Engine)
  2. Restart your Mac

If neither of those work, report back here and we'll do some more diagnostics.


Thanks for the reply JMichaelTX,

I quit and relaunched the Engine and restarted my mac. Still asking me to enable it access with Accessibility. If it helps in any way, there are two dialog boxes that are asking me.

Because I can't get past this part, I can't use that macro you linked me to. Although I was able to copy out the bash script. Running it yields no output.

You know what… I just realized that after running that bash script it no long tells me that secure input is enabled… so that must’ve fixed it. I can use the macros that are defaulted in KM, but cannot set hotkeys to make my own.


Keyboard Maestro is not enabled for accessibility:

Note that Keyboard Maestro is not checked. Click the Lock icon, enter your admin details, and then tick the Keyboard Maestro entry.

If you are using 10.10.0-2, then you may have ongoing problems.

If you are using 10.10.3+ then you should have no problems, but you may need to restart.