Action “Execute AppleScript” lost default icon

KM works as usual,but all my pure AppleScript macros lost the default icon.

Please help me out.

Thanks a lot.

@peternlewis @JMichaelTX @ccstone

Reinstall app did no help.

Have you tried clicking the icon and hitting "Delete" key? If something was inadvertently pasted over the default icon this would return it to the default.

Oh, it's for ALL of them. Not sure then.

If you add a new Execute AppleScript Action, is its ison also missing?
What changes have you recently made to your Mac?
What macOS are you running?

Yes,new macro with Execute AppleScript Action has the same problem.

I don't remember what changes I made will change how KM behave, just use macOS the same way in my everyday life.

Keyboard Maestro 8.2.4 on macOS 10.14.3

What confuses me most is that download KM and drag it to Applications folder and overlay install did not help.

I don't remember I had done this to Action icon.

I never delete anything inside Keyboard
Copy ExecuteShellScript.icns and rename it to ExecuteAppleScript.icns doesn't help.

The icon is based on the system icon for the .scpt file type.

My guess would be your system Launch Services cache is screwed up.

Maybe CleanMyMacX did something to my System Launch Services cache.

Do I have to reinstall the system? Or there are some other solutions to fix the system Launch Services?

Thanks very much.

There are ways of resetting the launch services cache. I'm not entirely sure how, but Google should find it.

Thank you very very much. :relaxed:

Sadly, I failled on solving this problem.

Tried all this:

  401  find /System/Library/Frameworks -type f -name "lsregister" -exec {} -kill -seed -r \\n
  404  sudo find /private/var/folders/ \( -name -or -name \) -exec rm -rfv {} \;
  405  sudo rm -rf /Library/Caches/;
  406  killall Dock
  407  killall Finder
  408  sudo find /private/var/folders/ \( -name -or -name \) -exec rm -rfv {} \;
  409  sudo su
  410  sudo find /private/var/folders/ -name -exec rm -rf {} \;
  411  sudo rm -rf /Library/Caches/
  412  sudo rm -rf /Library/Caches/; killall Finder
  413  sudo find /private/var/folders/ -name -exec rm {} \;
  414  sudo find /private/var/folders/ -name -exec rm -rf {} \;
  415  sudo mv /Library/Caches/
  416  sudo reboot

I will reinstall system when there are some bigger bugs on macOS.

Running this now:

find /System/Library/Frameworks -type f -name "lsregister" -exec {} -kill -seed -r \;

Reset Launch Services under Snow Leopard

  1. Log in to the affected account.
  2. Open Terminal, located in the Macintosh HD > Applications > Utilities folder.
  3. At the prompt, type the following command exactly as written:
    find /System/Library/Frameworks -type f -name "lsregister" -exec {} -kill -seed -r ;
  4. Press Return. The Launch Services database is rebuilt; it is finished when the Terminal prompt returns.
  5. End the Terminal session by doing one of the following:
    Press the Control-D keyboard shortcut.
    Type exit and press Return.
  6. Quit (Command-Q) Terminal.
  7. Check to determine if the problem is resolved.

Onyx failed too.

CleanMyMacX would be my first suspect.

1 Like

I'm using the Setapp version CleanMyMac X. Heard of CleanMyMac delete something belongs to the System, never thought of I will encounter this problem(never change any of CMM's default setting, just press scan and clean button). :joy:

Maybe it's time to remove CMM from my application list.

Thank you for kind reminder. :blush:

1 Like