Activate App Macro Doesn't Work for Certain Apps

This macro works well for most of apps

the same macro don't work for few apps like Finder

When I type Option+Shift+F my shortcut for this macro, the current app window turns gray at the top, but the Finder app doesn't launch.

Your Finder should already be launched (it should be running all the time you are logged in), and is almost certainly being activated. But if you have no Finder windows open there's nothing to come "in front" of your previous app, so you may not realise what's happening.

Try opening a Finder window, switching to another app (like Chrome), then running your macro. Or if you want your windowless Finder to activate and open a window, tick the "Reopen initial windows" box in the "Activate Finder" action.


Hey @Yohan,

This problem bites me now and then, even though I have myself well trained to hit ⌘⌥H if a Finder window doesn't immediately show.

I'll be thinking “WTF!” and hitting my switch-to-Finder hotkey more than once...

The appended macro contains two easy workarounds for the problem.

  1. Hide other apps if only the Desktop is open (no windows).
  2. Open a new window of the user's choice if only the Desktop is open (no windows), but leave other apps visible.


Download Macro(s): Activate Finder with Activate a Window IF Needed v1.00.kmmacros (9.8 KB)


Keyboard Maestro Export

  • Macros are always disabled when imported into the Keyboard Maestro Editor.
    • The user must ensure the macro is enabled.
    • The user must also ensure the macro's parent macro-group is enabled.
System Information
  • macOS 10.14.6
  • Keyboard Maestro v10.2

1 Like

I understand now why I'm having this problem. Thanks @Nige_S :+1:

Thanks @ccstone for this awesome macro! :raised_hands: I just download and import it. Trying to use it.

It looks if the Finder window is 'Minimize' status, my basic macro and your macro don't work to me.

Is there action that 'Unminimize' app on Keyboard Maestro? I think Finder should be Unminimize first.

Hey @Yohan,

Make sure the macro and its parent macro group are ENABLED.

There is no minimized status involved in my macro.

It looks to see if there is only 1 window open. When that is the case then NO windows are actually open – only the Desktop (Apple seems to think of the Desktop as a window).

The enabled action in the macro HIDES other apps when switching the Finder and NO windows are open.

The disabled action (which you can switch with the enabled one) OPENS a directory of your choice.

If actual windows are open in the Finder then the macro ONLY switches to the Finder and nothing else – since windows are already open and will visually clue you in to when you're in the Finder.


1 Like