After upgrade to 9, my KM keyboard shortcuts no longer type the strings called by the macro

The engine is running. (Launch engine at login is ticked in the preferences.)
The keyboard shortcut triggers are active in the Global Macro Group.
I type the trigger but only the trigger characters are displayed as I type them but the expected word or phrase doesn't result from the Keyboard Maestro macro. For example in the editor I set up a macro to upon typing "kwaf" the macro would type "Keywords: American Football" [of course ignoring the quotes].

I restarted my Mac. I quit KM and relaunched it.

I suspect that this is something simple because Keyboard Maestro has always just worked.

My OS is 10.14.5 but KM-8 was working until I upgraded.

I'm afraid you really need to post an image, or better, upload the macro(s) you're having trouble with, as there's only so much we can do from descriptions alone. At this point, all I can tell you is that this example macro I just whipped up in KM9 on 10.14.6 works exactly as it did in past KM versions:

Example Macro.kmmacros (1.4 KB)

Sounds like you are suffering from Accessibility permission issues where the system tells Keyboard Maestro that it has accessibility permissions, but actually it does not. Try the Interactive Help (Help ➤ Interactive Help), it has a special detection for this Mojave/Catalina behaviour.

See the Accessibility Permission Problem assistance page for more info on solutions.

@peternlewis suggestion solved the problem. Thank you!!