Alert Sounds

I never had this issue with BTT but trying out KM I'm getting alerts sounds most of the time I run a for key. I have a macro pad that execute non conflicting keybpord commands like CMND+Shift+Option+Control+F20 set to trigger a keyboard output of something like control+ right arrow.

On my keyboard if I type Control+Right Arrow my machine switches spaces to the right, when I run the action through KM it creates an alert sound as well as switching spaces to the right.

I have quite a number of similar actions and trigger that usually trigger alert sounds.

I had decided to turn off alert sounds when I couldn't figure it out, but other apps issue useful alert sounds I would like to still hear.

Surely this is not a "feature" of KM to play an alert sound for every action.

The sound you are hearing is presumably the beep applications/the system tends to make when you press a key it does not understand.

The issue with simulating arrow keys to move spaces was caused by a system change several systems ago, though I believe it was resolved in recent versions of Keyboard Maestro. Are you using version 10.2?

thanks for the reply. I am on 10.2 though. Any possible solutions?

If you have had the action since before, you may need to replace it. Re-record the keystroke.

Other than that, as far as I am aware, simulating the key should cause the Spaces change.

i just purchased this app and have not updated it. Any possible solutions

Just so we are clear:

  • If you type Control-Right Arrow, it moves Spaces.
  • If you create a Type a Keystroke action, and set it to Control-Right Arrow, select it and click Try, it does not move Spaces?

the actions work but they trigger an alert sound. not just CNTRL+Right Arrow but most of my KM shortcuts. Using Hot Keys on a USB keypad that should have no conflict. CNTRL+Right Arrow is just one example. When I turn off KM these buttons doe not trigger any alert sound.

Taking a punt, but have you accidentally chosen "typed string" rather than "hot key" triggers?

And have you still got BTT installed? Perhaps you're managing to fire off both systems...

I think rather than talking in general, perhaps pick a single simple macro that is causing the issue, and post that here.

Also, ensure Keyboard Maestro is not complaining about any issues (there are no warning messages or warning triangles in the editor window or the status menu).

Also check the log file, the Editor.log and especially the Engine.log file (Help ➤ Open Logs Folder) to ensure there are no reports there of issues.

thanks for the reply Nige_S. I'm getting the issue using the hot key and this device key triggers. I am running a BTT profile with one hot key still but when I turn off BTT the issue persists. (My goal when purchasing KM was to replace BTT but the one action I purchased KM for KM can't do as it claims but that's a whole other issue)

If I turn off all shortcuts and any key remapping and just reprogram a device key on my USB macro pad to output control + right arrow it executes the command and plays an alert sound. i turn off KM and press the button I don't get the alert sound.

Is there a way to just turn off alerts sounds for KM and keep all my system alert sounds?>

i think in general it shouldn't be making so many random alert sounds

How do I turn off KM alert sounds

It's making alert sounds because something is wrong -- treat the cause, not the symptom.

You usually get the system beeps when trying to pass keystrokes to something that isn't in a state to accept keystrokes, like when you try to type while a system alert is open. But to have even a slim chance of working out why that's happening you'll need to post an example macro -- instructions here -- and maybe even a screen capped video (since this is likely state-dependant).

If I turn off all shortcuts and any key remapping and just reprogram a device key on my USB macro pad to output control + right arrow it executes the command and plays an alert sound. i turn off KM and press the button I don't get the alert sound.

the only issue is the alert sound. I'm not seeing any errors or warning triangles in KM.

is there a terminal command to disable KM from making alert sounds? I don't have infinite time to troubleshoot this productivity tool

And the most likely explanation is that whatever you are "sending" the ⌃→ keystrokes to doesn't know how to interpret them, so it raises an exception, and the systems beeps. It is not KM doing the beeping!

There's a subtle but significant difference between actual hardware events -- you pressing the ⌃ and → keys on your keyboard -- and simulated hardware events -- KM simulating you pressing the ⌃ and → keys on your keyboard -- and you could be falling foul of that. Plus, Spaces is a particularly half-baked piece of Apple engineering and can be a pain to macro.

Try something easy, like a macro that uses a keyboard hot key trigger to activate Safari, and see if the beeping still happens (if it does, post the macro for others to help troubleshoot). Then try the same macro but triggered via your macro pad.

Use the Interactive Help, Something unexpected is happening, and find out what macro is being triggered.

Keyboard Maestro itself almost never plays any alert sounds (the only exception would be significant errors like failing to write the macro file), and they would also be reported in the Engine or Editor log files.