All key-press / typing stopped working after monitor SW install

Love KBM, been using for many years. My uses are pretty basic - I automate small, repetitive tasks like typing my email address.

After installing software for a new monitor (LG 34wk650) which includes keyboard shortcuts for window positioning (including restart), my KBM suddenly lost all ability to deal with keystrokes. For example:

  • macros that simply "Insert Text [] by Typing" seem to trigger, but don't actually type anything
  • trying to fix, I tried to reset the Hot Key trigger key-combination, only to find
    the "This hot key" input box no longer accepts keystrokes, so I can't change back
  • my other non-keystroke macros still work

My initial thought was some interference with the new SW, so I went into "System Preferences" --> "Security & Privacy" --> "Accessibility" which "Allow the apps below to control your computer." I had KBM and the new SW both enabled, so I disabled/revoked permissions form
the new SW and restarted - but to no effect.

It feels like a permission issue or conflict - hopefully that someone has run into before. What is twice as curious is that keystrokes in some KBM input boxes stopped working at the same time... maybe some SW issue? Except i've been running stable for 2+ years. Any thoughts on where to begin?

On a Macbook Pro 2017, running Catalina 10.15.4

You might try disability and re-enabling KBM accessibility just in case something got glitched. Also the the LG monitor actually installed some SW, maybe it's intercepting key input.

Thanks Naven - you were correct... I shut down KBM, disabled/removed the entries from "Accessibility", started KBM back up, and let the app re-prompt for permissions. Works again!

HOT KEY is grayed out, not accepting any key or combination of keys. Do not have an LG monitor. iMac Pro, current Catalina using Apple Magic Extended Keyboard. Have gone into Accessibility, unchecked KM Engine and APP. Exited, rechecked the boxes, still no joy.

Update, I have exported all macros. Then I uninstalled KM. I then reinstalled. System Accessibility, unchecked KM. Closed System, reopened and reselected KM. Still, no joy for curing the grayed out add HotKey prompt. Help, please.