All KM macros using Apple Function Keys have stopped working

Did something change in KM? Have been using Apple's function keys (F1 through F19) for years as KM hotkeys (most are not used directly, most are control key + function key or shift key + function key but some are triggered by just the function key). Recently all of these macros stopped working and I cannot figure out what changed.

They do still work if I change the hotkey (to say pressing the control and the number "1"). If something has changed and the function keys can no longer be used I can live with it, but well, I'm old (seventies) and have used the same function keys for 20 years as hotkeys (first with Quickeys, now with KM) and they worked fine all these years with both. I've attached a screenshot to show that these were setup on function keys (they just no longer work)

If it matters I'm using Mojove on a 3,1 Mac Pro with a standard wired Apple keyboard. TIA for any help that can be provided.

Screen Shot 2022-06-14 at 1.40.12 PM

If you haven't already, check System Preferences->Keyboard and the Keyboard pane to make sure "Use F1, F2, etc. as standard function keys" is checked. Also, if you put the cursor in the "Hot key" trigger box of one of your macros, does pressing a function key register?

Otherwise, do have a spare keyboard you can try in case it's a hardware problem? And, as always in these cases, have a think about what's changed between when it was working and now (OS updates, other software installed, etc).


Thanks for helping Nige_S! Other key related issues arose and your suggestion to try a different keyboard solved the problem. Who knew using the same keyboard since a small forever would wear it out :open_mouth:

Thanks again!