Application-specific macros can't be run because KM thinks the app is "installed in a virtual machine"?!

I’ve got a hot-key enabled macro in a Macros for Chrome group that’s supposed to only activate in Google Chrome.

When I try to activate the macro, I get an error:

The “Google Chrome” application cannot be started.
The application is installed in a virtual machine that cannot be located. Make sure that the virtual machine hasn’t been deleted or moved to another location.

I’ve tried “repointing” Chrome to the actual file location and deleting it and selecting the open application but neither helps.

FWIW the macros simply creates a new tab and fills in some info. It’s basically the Chrome version of this Safari macro I originally asked about (which works fine now): Can’t seem to get variables & clipboard to work

Does anyone know how to fix this problem?

The actions are basically doing AppleScript commands along the lines of:

tell app "Google Chrome"
end tell

The system is then trying to launch Google Chrome. Instead of choosing the Google Chrome in your Applications folder (which I presume is there (and probably running?)), the system is deciding that what you really mean is the Google Chrome in some virtual machine (a Windows emulator of some sort perhaps).

This is obviously a crazy choice for the system to make, but apparently the system is not entirely sane on this point.

You can try reseting your launch services cache, try ensuring Google Chrome is already running, and perhaps try restarting. Unfortunately, there isn’t a lot that Keyboard Maestro can do to avoid the issues when the system goes off the rails like this.


I have had the same issue with my AppleScripts for Outlook.
It happened because Parallels Desktop was setup to share applications between my Mac and Windows (VM).
When I disabled this, then my AppleScripts worked again.

1 Like

I actually do have Parallels installed but haven’t used it in a while. But using Onyx to wipe the Launch Services cache did the trick. Thanks!