Are "Insert Text by Typing/Pasting" working in Mojave?

I'm a 25-year QuicKeys user who has switched to KM, and I'm gradually recreating all of my QK macros in KM. So far, I'm not able to get any "Insert Text by Typing/Pasting" macros to work at all. (QK sometimes had problems pasting text. In those cases typing text always worked reliably. But so far, I can't get either to work in KM.)

For testing purposes, I created a macro with both actions, followed by a "Play sound" action:

  1. Insert Text by Typing
  2. Insert Text by Pasting
  3. Play a sound

But when I hit the hotkey, the text is never inserted. (I've tried this in both Mail and TextEdit.) All I get is the sound. The first two steps are seemingly "ignored." This is why I'm wondering if there's perhaps a new issue with text-related macros in Mojave. Or might there be another reason for this behavior?


Please post/upload your macro (click for instructions) so we can see exactly what you are doing and test for ourselves.

I've used both of those Actions for years, and they always work well, IF you properly setup the app to receive the text to be typed/pasted.

For example, click in the body of a TextEdit document, and trigger your macro. Make sure the macros are in a Active Macro.

Thanks, but of course I've clicked in the appropriate text-receiving fields. I think the detail I provided (including my 25 years of using macros) suggests I know enough to know that one must click in a text field in order for a text macro to work.

That's why I specifically asked if this might be a new issue related to macOS Mojave. That was a key component of my inquiry. If you're not running Mojave, you may not have encountered this behavior.

"Make sure the macros are in a Active Macro."

If they weren't, the Play Sound action that I described wouldn't be working.

Thanks again.

Sorry, I must have had on my "Mojave" blinders. :wink:

I stay away from OS betas, and even recent releases of any software.
Thanks for serving on the cutting edge. I'm sure @peternlewis will find your testing helpful.

Welcome to Mojave beta bugs. And probably finale bugs, but you never know, Apple might surprise us!

From the wiki:

  • Note that OS X Mojave (Betas at least) has a serious problem adding accessibly for Keyboard Maestro Engine. Specifically after it is added, you can click the checkbox but it wont necessarily turn on. Resolve this by deleting the Keyboard Maestro Engine entry from the Accessibility list and relaunching Keyboard Maestro Engine (Keyboard Maestro File ➤ Quit Engine, File ➤ Launch Engine), and then you can check the checkbox to enable accessibility permissions.

  • Note that OS X Mojave (Betas at least) has a further serious issue in that even after it claims to have enabled accessibility permissions, the system may still be refusing to allow access to the event queue (symptoms include not being able to set hot keys and typed keystrokes not working (including Command-V for paste)). Restarting your Mac seems to resolve this.



I had the same behavior of KM macros not inserting text. The macros are simple: check that target application is frontmost and then insert text. My problems with failed text macros happened in El Capitan and Sierra. The macros worked reliably for a year. Then, it took longer for text to be input. Then, the macros didn't work at all. I tried quitting and launching the KM Engine and the KM editor. No help. I quit and restarted the target application (Sigil). No help. I shut down my Mac. No help. I switched to QuicKeys that worked intermittently. I got a newer Mac Pro (2012) and upgraded to Sierra. The text macros worked for about two weeks. They worked slowly for the past week. Now, the text macros don’t work at all. They failed suddenly while I was using them.

I installed Sierra on an erased disk, so no bad files from El Capitan were passed to Sierra. I have no clue why KM's text macros have failed. Any suggestions?

You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes, selecting menus, copy/paste, etc), you need to toggle the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again.

Since text insertion was working and suddenly failed, I don't think Accessibility is the problem. I had checked them all when I upgraded to Sierra and checked them in El Capitan the first time it happened.

Greg T

I am running Keyboard Maestro under Catalina macOS 10.15.1.

I had the same problem as soundsgood. This worked for me. When I double clicked the action “Insert Text by Typing” on the right the text “Insert Text “” by Typing” had what looked like an empty check box to its left. Clicking on it did nothing. But clicking and holding with the Control key down gave a pop down menu with option “Enable Action”. Selecting that option solved the problem.

By the Way, the box was still empty, but the upper and lower edges were slightly thicker. And now clicking with Control key down shows “Disable Action”.


I believe you mean the action’s icon, which is a clipboard (used frequently in Keyboard Maestro for things related to the system clipboard).


You can enable or disable actions using the contextual menu, or the gear menu in the action (click on the gear symbol at the top right of the action), or by selecting actions and clicking the ✓ button at the bottom of the macro detail column (you can enable or disable macro groups or macros by clicking the corresponding ✓ button at the bottom of the macro groups and macros columns).

When an action is disabled, it is dimmed. For example: