Auto-Save in Word not working anymore?

For a long time I had this working just fine -- basically just "if Microsoft Word is running," then cmd-S every 30 secs or so.....

For some reason it does not fire any more? I am not sure what went wrong.

I did some searching and tried this as well but also no luck - Auto-Save Microsoft Word It works when I manually click "run," but not just on its own.

Any ideas? IS there some known issue? I am still on Ventura if it matters.

I don't have Word but I have just tried a simple test macro with TextEdit along the same lines and it works as expected. That was also under Ventura.

Here are some ideas for experiments so you can track the fault down:

  • Try substituting other applications for Word to see if the problem is just with Word.
  • Include an alert to the start of your macro to check that it is running ("cave man debugging" deluxe!).
  • Make sure that Cmd-S is being sent to Word (check "Send to" under the gear icon of the action).
  • Try replacing that action with a Select or Show a Menu Item action and target Word's Save menu that way.
  • See "Situation #4 -- After Working Fine for a While" on this Troubleshooting page.

... and all that after you have tried Help > Interactive Help.

Let us all know how you get on.

Thanks for the help! It appears I have it back up and running! I had already altered it to select the menu item "File-Save", so it no longer showed CMD-S (I do see, now, though, how to check for "Send to" in the future. That could have been the culprit, but then the File-Save wouldn't have suffered from that issue since it was tied directly to Word.

One thing that SEEMS to have been the culprit, though was the macro lived in a "Word Macro Group" folder. That folder is supposed to be active whenever Word is running. But, reading up here: - trigger:Application [Keyboard Maestro Wiki] - I decided to put it in the global folder, and not just the Word folder. Voila! Something about it being nested in the Word folder was making it to where it never fired (even though it used to???)

1 Like

It's good to hear that all is now well.

Is it possible that your "Word" macro group is disabled? Remember that macros can be disabled not just manually but as the result of a Set Macro or Group Enable action in another macro; might you have been experimenting with that action at some point? You could try recreating the macro group from scratch under a new name and then see if the macro runs when it is within that group.

ah - not sure! Will look into that and see. Thanks again for your help!

1 Like