Big Sur killed KM on Windows under Parallels

I am running Parallels Desktop Pro (16.1.0) with Windows 10 Home. I had previously updated to KM 9.1 with no difficulties experienced. Last night, I updated to Big Sur. My KM macros still run fine on the Mac, but now will not run on Windows. There is no error message or other indication -- the macros simply do nothing. (I am not in secure entry mode anywhere, and have freshly rebooted both Mac and Windows.)

1 Like

UPDATE: This is still going on. If I want to use KM to generate custom content of an email, I must do it in the Mac domain, copy the text, and paste it into my Windows email running under Parallels. No KM macro works under Parallels/Big Sur any more. Troubleshooting help would be greatly appreciated.

Are you able to provide a screen recording or something of what you’re trying to do and where it fails? It feels like there’s not much here for us to go on

Great idea. Here's the macro working in the Mac environment and not working in Windows under Parallels. This worked perfectly up until either the Windows update or the Parallels update. Here's a link to a Dropbox folder containing a .mov recording. Best,

I STILL don't have Maestro functionality in Windows running under Parallels, and it's killing my productivity! I posted the requested screen recording showing the issue. PLEASE -- if anyone has any ideas, share them! Many thanks, Brian

Starting to feel marooned here. Am I the only one in the world who can't get KM to type text in Windows apps running under Parallels? It worked before and suddenly quit, and I desperately miss that functionality. Is there a process I can use to track the progress of a KM communication to see if it's being blocked in Parallels or Windows? (I did verify this already: In Parallels -> macOS System Shortcuts, the option to "Send macOS system shortcuts" must be set to "Always".)

PLEASE help!

This is a long shot, but write to Parallels support and ask if there are any KM users?

]see also Suggestions for using KM in Windows 10
and PM to the contributors o the thread of their experience....

Thank you for the suggestion. I reported it a while back, but didn't get a response. I just sent a new report along with my screen recording of the problem. I hope to hear back this time.

I suspect it will turn out to be a setting that got changed or reset during the update process. I hope it's that simple.

I have become totally dependent on the excellent KM for my productivity!


I did some isolation on my own, and contacted Parallels support.

My findings: As an example, I have a macro that opens a dialog box for input, then types a form letter using that input. It works fine on the Mac. If I type the trigger in Windows, zero response. If I type the trigger string in a Mac app and fill in the variables there, then set focus to the windows app and click OK in the macro box, the macro types the letter in the Windows app. Therefore, the trigger string is not getting passed from Windows via Parallels to the Mac, but the Mac typing is getting passed to Windows.

After an hour on remote session with very puzzled Parallels first- and second-tier support, they asked for the following information from KM: "Kindly contact the Keyboard Maestro application vendor to check if it is possible to install a plugin that could be installed within the Windows virtual machine to fix the issue." Any response to this that I can pass on would be greatly appreciated.