Bug: cannot open finder selection anymore

I don't know what happened but since a few weeks this very simple shortcut doesn't work anymore:

Open the Finder Selection Action (v11.0.2)

Open the Finder Selection.kmactions (622 B)

When I try this I get the following error message:


I have the same shortcut with Adobe Photoshop, and that fails too, so I think it's a general problem and not application related?

I've seen similar errors posted in the past with older MacOS versions and other apps but I did not see a clear solution... What is going on?

Addition: as per suggestions in other posts I've tried it with multiple files with exactly the same result.

Thanks --Mike

1 Like

Have a look at this recent thread on the same issue to determine if any of the suggestions provide a resolution.

Hi @NaOH,

Thanks for the link, indeed completely similar observations, but no solution... Hoping that @peternlewis cracks this.

Thanks & cheers --Mike

The solution is to remove the Quarantine bit, or to ask Apple to fix the API so that it does not return -128 “user canceled” when the quarantine bit is on on the file (except maybe that is exactly what Apple considers to be working as designed).

There are at least two solutions in that thread -- use a Shell Script action instead, or set the quarantine bits of the file(s) before you open them.