Bug: Prompt User Input doesn’t respond to keyboard

The dropdown doesn’t respond to keyboard arrows

Attached GIF:

Expected: Pressing Down once moves to second option.


I don't have that issue. My arrows work and tabbing does as well.


Do you have this setting enabled?

It's called something slightly different in pre-Catalina versions, but it's in the same place.

This is a knownl bug (behavior) in KM that has been reported many times.
@peternlewis has said every time that it is out of his control, that it is the behavior of the Apple control. I've never understand that, since I don't see that behavior in any other app other than KM.

As a workaround, you might try this: When the popup is selected, press SPACE and then the arrow keys should work, at least most of the time. :wink:

1 Like

thanks, let me try...

It is out of my control in that the system handles tabbing between controls and type ahead of menus, and so I have no control over there behaviour.

I don't disagree that it is a problem that is unique to Keyboard Maestro Engine, as I don't recall seeing the failure in the behaviour anywhere else, so presumably there is some aspect of Keyboard Maestro Engine that the system does not like, or that tickles some system bug. But unfortunately, I have not the slightest idea what that might be, or how to change it, and since, as I said, this is entirely handled by the system, there is no way for me to figure out what part of the system is unhappy with what part of Keyboard Maestro, and so even if there was some change I could make to Keyboard Maestro Engine to avoid tickling the bug or annoying the system (which is not necessarily the case), there is no way for me to find out what that change is.

@peternlewis is there something anywhere (ie Console log) that could shed some light on this?

@JMichaelTX thanks, tried that, but even using Space doesn't work...

EDIT: Ok, the Space thing gave me an idea, so what seems to work is:
Press Space two or three times, then ESC, then Space, then the arrows work
:laughing: :roll_eyes:

None that I have ever seen.

It seems like the system is just swallowing the keys randomly. Sometimes I find just pressing the arrow keys some random number of times works. It is as if the system thinks the focus point is somewhere random and eventually gets around to moving it to where it should be.

@peternlewis Do you have Little Snitch installed?
I ran a macro and Little Snitch intercepted it, asked me if I wanted to enable GUI scripting:

which is odd because I don't have any shortcut keys enabled in Little Snitch:


What does this have to do with this topic?

thought Little Snitch might be the culprit, as it intercepted a KM macro.
Thanks, re-made the script to avoid using the dropdown

I mean, it MIGHT be the culprit