Cannot simulate keystroke due to ambiguous keyboard shortcuts

Hello there,
I am trying to put some keyboard shortcuts in Adobe Lightroom on my F keys. Now I have run into a strange problem: The keyboard shortcut to rotate an image to the left is ⌘[ - yes, that's an opening square bracket. On my German keyboard layout I can type an [ by pressing ⌥5. So to rotate an image to the left in Lightroom, I have to press ⌥⌘5.

Now, if I press this combination on my keyboard in Lightroom this works. To my surprise, when I set up this very simple KM macro it did not work, but did switch to another workspace instead.

It turns out that Lightroom has two shortcuts, one it calls ⌘[ to rotate the image and another one it calls ⌥⌘5 that switches to another workspace. The interesting thing is, that if I use the shortcut on my keyboard in Lightroom it works as expected and it turns my image. If I simulate this very same key combination via KM, it does trigger the other shortcut instead.

Now my question: Is there any way to let KM simulate a [ press specifically and combine it with a press?

Thank you!

You could try changing the keyboard layout and setting it that way, but simulated keycodes are based on the actual keycodes, so it’s not clear what pressing the [ key would do when adding the command-key does something different.

Alternatively you could use the Select Menu Item action instead.

Or you could use the System Preferences to adjust the Rotate Left (CCW) menu to a different shortcut.

Not exactly sure, what you mean by «setting it that way»? However, using the System Preferences to assign a different shortcut worked for me, so I consider this problem solved. Thank you Peter!


1 Like