Cannot Type a Keystroke

Just downloaded Keyboard Maestro, and can't get the most basic functionality to work: being able to type in keystrokes as part of the action to be executed.

I was only able to complete the tutorial by selecting the function key from the menu. Now I want to create a macro that, for example, presses the "d" key, there is no way to select that from the menu, and I can't get it to register that I'm pressing "d".

I click on the "simulate keystroke" box, so it says "type" and awaits a key press, but nothing happens when I press any button on the keyboard.

I'm using OSX 10.9.4


Is Accessibility turned on in the system preferences and Keyboard Maestro and Engine allowed to function?


Yes, it is. Hoped it would be as simple as that, but must be something else wrong.


Just to make sure it's what you're doing.

  1. Insert the "Type a Keystroke" action:

    (by default it's going to press Return)

  2. Click into the text box so it appears selected:

  3. Press d:

Are you saying that you're doing this and it's not replacing "Return" with "D"?

Yes, that’s exactly the problem. There is no change from 2. when I try to press any key on the keyboard.

I should add that, if I select a key from the drop down menu, the thing does work. Problem is I can’t select letters from the drop down, and I would also like to be able to add keystrokes like Cmd+Shift+D, for example.


Sadly, the Mavericks accessibility permission system is a little flaky.

Ah! Ok, will try restart, but can’t do that for a few hours (rendering right now).
Thanks for all your help everyone.

Let us know if it works or not. I don’t like recommending restarting as a solution, it generally isn’t, except for this particular case, and cases where odd things are happening that indicate some sort of system wide corruption. But this particular case, sadly, restarting seems quite often to be necessary after first configuring the accessibility permissions.

It is now March, 2017 and I am now having this problem too - i.e. when I try to type a new keystroke to be remapped, nothing happens.

I’ve tried simple keys (“a”, “b”, “c”, etc… (of course without the quotes)), Cmd+Keys and Function Keys, but none work. I am using the latest version of KM (when I tried to update it told me I have the most recent version - i.e. 7.3.1) and I’m using the most up to date Mac OS (10.12.3). I also tried to restart the KM engine as suggest above. Nothing helped.

What I was trying to do is get Ctrl+C on my Logitech K-750mac keyboard to work like Cmd+C in Chrome for Mac Os and then I was going to do the same for Ctrl+V.

As a test I now switched back to the standard Mac keyboard that came with my Mac (late 2014 27" retina) and I’m finishing typing this message on it. It too could not record a keystroke in KM for a macro (even after turning KM off and then back on again), so it is clearly not a keyboard issue.

What do you mean by this?

Are you trying to type the key for a hot key trigger? Does Keyboard Maestro say “Type” and then you type a key and nothing happens?

If so, the likely culprits are:

  • The Keyboard Maestro Engine not running
  • Accessibility not enabled (for the editor or the engine)
  • Secure Input Mode enabled

You can tell the first one by checking that the Keyboard Maestro status menu item is there, and at least some macros are working (eg Command-Tab brings up the Keyboard Maestro application switcher).

Keyboard Maestro 7.3.1 should detect the other two and report them either in the Keyboard Maestro editor window (bottom right corner there is a warning triangle) orin the Keyboard Maestro status menu.

Please don’t yell at me for raising an old thread, it’s still relevant.

I was going through all the steps and nothing worked. Spent my while evening trying to get keyboard shortcuts to work.

Then noticed the group was grey. I guess you can deactivate a group. i have no idea how that happened, but I reactivated it and my keyboard shortcuts now work. Arrgh. Created an account just to add this for any future searcher.

I'm having the same problem, another app is the culprit as I got this message from KM

Do you have Webroot SecureAnywhere installed? If so, turn on the Pause Secure Keyboard Entry option.

Otherwise, the wiki Secure Input Problem page has some more information on the subject, and the Smile folks have a very good page which lists a variety of applications that can cause the problem.

Thanks for the quick reply. In my case it is 1Password that is the problem, so I closed it.

1 Like