Can't access "phantom" menu commands in Evernote

I'm attempting to use macros to select menu commands in Evernote to change the sort order of displayed notes (i.e., Alphabetically, Last Created, Last Updated). I was able to do this with QuicKeys, but I'm having trouble replicating it in KM.

I'm in KM 8.2.4, Evernote 7.4, and macOS 10.14 (beta). (I've also tested this in macOS 10.12.8 with identical results. So the beta OS seems irrelevant.)

The first menu command I'm attempting to select is View > Sort by: > Title:


But when attempting to select that menu in KM, "Sort by" is missing from the View menu:

So, I tried Record Mode, and KM found the "Title" command:

But when I run the macro, I get this error message:


Any suggestions for alternative methods? :-)

Well, I'm still running Evernote 6.11.1 (455059) on macOS 10.12.6, and the View menu does not offer a sort item. So I can't test.

But you might try this:


Start the Sort with a caret, which tells KM this is a RegEx pattern and to start at the beginning of the menu item name:

So it should match Sort + anything.

BUT, it could be that Evernote doesn't build that menu item Until you click on the View menu.

Thanks for the suggestion. Perhaps you're correct that Evernote doesn't build the menu item until one clicks on the View menu. So, on to Plan B…

What's the best way, in KM, to:

  1. Click on a menu;
  2. Drag down to the sub-menu;
  3. Drag right to an item within the sub-menu;
  4. Click.

I did this a lot in QK, but the method in KM isn't quite obvious. Steps 1 and 2 are obvious, but I'm stuck at how to add steps 3 and 4.

Also, while that will get me to the first command in the sub-menu, for the other commands, I'll have to modify step 4 and add another:

  1. Drag down again (within sub-menu)
  2. Click

Record Mode isn't capturing these multiple moves, so any advice would be appreciated.


Did you try it?

Yes, I did. Unfortunately it didn't work. Thanks again.

I wonder if introducing pauses helps here - while the dynamic item gets built.

Good point.

@soundsgood, so you could try something like this:

  1. Show Menu "View"
  2. Pause Until Menu path "^View>Sort" is enabled
  3. Show Menu "View", "^Sort", "Title"

If #3 doesn't work, you might try "type select":
Insert Text by Typing "Sort"
Type Keystroke "→"
Insert Text by Typing "Title"
Type Keystroke RETURN

I finally had time to try this, and the latter method works! Thanks!

For the record, I'm not saying that the former method (the 3 steps) did not work. I actually didn't try that method, because I wasn't sure how to interpret step 3. (Are "View," "^Sort," and "Title" intended to be three, separate actions? Or one? Also, what's the purpose of the "^" character in "^Sort"?)

You're clearly knowledgeable, so I don't doubt your advice; I simply didn't understand what you meant. But it was immediately evident that the second method would work, so that's what I did.

Thanks again.