Can't copy file to encrypted folder (vault) created by Cryptomator

I'm trying to create a simple macro that copies a file to a Cryptomator vault (Copy a File action), but I always get this error message: couldn’t be copied because you don’t have permission to access “Backups Folder - Encrypted”

But when I manually copy the file from the original folder to that encrypted folder (vault), no issues. I know that this is not a normal folder or volume (can't remember what it's called...)


What's weird is that some files are copied.
For example this video and this zip file were copied, no errors:


Then if I tried to copy 2 files manually, two that were not being copied, no issues:


So it seems that the issue is not with the vault itself, otherwise I wouldn't be able to copy the files manually, right? It also doesn't seem to be an issue with the files, because I can copy the exact same problematic files, if I do it manually. So there's something in the process with KM that's not working, but can't seem to understand what?

For those unfamiliar with Cryptomator (I'm still a newbie as well), here's the concept:
Cryptomator creates a folder with the name we want (the one on the right), where all encrypted files/folders will be added, with random names. Then it mounts this blue volume (on the left) and that's where the original files are added and stored

We are not supposed to put anything in the folder itself (the one on the right). That's just for encrypted files.

EDIT: tried to "trick" it using Carbon Copy Cloner and I got this error message that maybe someone can understand what's happening?

If I try to make changes to the volume by going to bottom section of the Get Info windows, I get this:


Again, if I copy the files manually, it works. This simple macro also works:


Another note: I tried using Terminal and the cp -r command and I got this error message: unable to copy extended attributes to /Volumes/UATgyaynaxFF