Can't Enable the Keyboard Maestro Engine on macOS Big Sur


OS is Big Sur. Just trying out KM for the first time but I can't get any macros to run. Upon further investigation it looks like the KM Engine isn't running. I've selected File > Launch Engine multiple times, but nothing happens and it never changes to Quit Engine, so I assume it never starts running.

I'm still getting the Accessibility warning in KM. I've enabled (and disabled, and re-enabled) KM in Accessibility multiple times, but the KM Engine isn't showing up there. Also, when I look for the KME in Finder, it has the incomplete icon. I get the "You can’t open the application “Keyboard Maestro” because it may be damaged or incomplete" message when I double click on it (see screenshot)

I've tried uninstalling and reinstalling twice, but no dice. Any idea what to try next?

Welcome to the forum! Sorry to hear about it not working when you tried setting it up. It sounds like you were trying to do the right things to get it working. By chance did you restart your computer in between any of your steps that you were describing? I'm not sure if that would resolve it as I've never run into that issues but it's worth a try.

Hi there,

Thanks for following up. I was actually able to resolve the issue by installing an older version of KM (the engine worked fine) and then updating to the most recent version from there. Maybe that will be helpful for others to know as well

1 Like

Excellent! Good thinking. Glad you got it working.

Note the following:

assistance:Accessibility Permission Problem [Keyboard Maestro Wiki]

Troubleshooting [Keyboard Maestro Wiki]

1 Like

Did you try running the KM Interactive Help?

I'm particularly interested in whether the app was translocated.

It's odd to see the engine disabled in the Finder.

@peternlewis – any comment?

99 times out of 100 (probably more), this is caused by security software SentinelOne corrupting the Keyboard Maestro Engine deliberately (and in my opinion, maliciously).


Ah, I bet that’s it. It’s a work laptop and it's something IT installed. Good to know!