Can't Input a Hot Key Trigger

All of a sudden, I can't add a hot key anymore.

I'm not sure what happened, but when the "Type" field is grey in the "This Hot Key" section, it won't accept ANY kind of input.

Key capture still functions perfectly.

I've had Karabiner Elements installed for a while without trouble, but I figured I'd uninstall it to see ⇢ no joy...

I have an external keyboard on my laptop, I've turned it on/off/on still no joy.

When I try typing a trigger, the "live event" (keyboard and emoji viewer) shows that the keys are registered - they just don' get too KM.

I've uninstalled KM as well and reinstalled.

I'm out of ideas...


Oh, and yes, between installing / reinstalling I've stopped / restarted Mojave every time ...

I have the same problem on my MacBook Pro. But the "Type" field is not greyed out. It will not accept any keys.

I had the same problem. It resolved when I turned off the access for KM in System Preferences then back on again. No idea why it worked but it did. Might be worth a try.

You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes, selecting menus, copy/paste, etc), you need to toggle the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again.

This is a bug in Mojave’s accessibility upgrade process - the worst part is that the system lies and tells Keyboard Maestro that Keyboard Maestro has accessibility permissions, but then fails the operations, so Keyboard Maestro cannot alert you to the missing permissions.


I'm sorry you guys are having issues with KM and Mojave. Mojave can be a real PITA.
But if you follow @peternlewis' instructions you should be fine.

Just so you know that KM can work with Mojave, I just setup a new iMac that came with Mojave, and migrated all my apps, including KM. After making the required changes in System Preferences, KM is working fine.

I just tried assigning a hotkey trigger to both an existing and a new Macro, and it worked fine with both.

Running Keyboard Maestro 8.2.4 on macOS 10.14.5.

Good luck to all, and hang in there. KM is definitely worth the trouble brought on my Mojave.

Oh I'm familiar with how great KM can be :slight_smile:
I've borrowed my wife's MBP while mine is in the shop - so I'm "tweaking" it to my taste ...

That said, thanks @peternlewis and @JohnAC - this worked like a charm :slight_smile:
I can now enjoy KM AND the Hyper Key in one single tasty package!

We are having a similar issue on one Mac running High Sierra. "Return" and "Enter" keys are not recognized in this action:

It works by adding a "left button pressed" trigger.

Also related (I think), the user is unable to add HotKeys to a macro. The field is highlighted but keystrokes are ignored.

I tried toggling the "Accessibility Preferences" as described by Peter, but issue persists. Any suggestions?

UPDATE: Re-installing KM resolved this issue. Perhaps a preference was not recognized.


I'm having the same issue using macos 13.2.1 (22D68) Ventura.

Is it possible to have someone looking at it.


Hey @prbrown,

Welcome to the forum!  :sunglasses:

It has been looked at...

Troubleshooting [Keyboard Maestro Wiki]

Look specifically at macOS Issues at the bottom.

  • What issue? More than one is described in this topic.
  • Are you a new user?
  • Did KM work before?
  • Did the problem occur upon upgrading your version of macOS?
  • Etcetera.



The issue might have been looked at, but still impossible to input any trigger (MacBook with Ventura).

I have tried all the workarounds described, Accessibility etc. no success.

Doesn't happen on my iMac.

Thanks for your help.


I've tried all the above and it still doesn't work.

My MacOS version = 13.2.1 (22D68)

I could finally fix the issue by resetting (all) the accessibility prefs using the Terminal.

Found the command line on KM's website, can't remember exactly where :wink:

The drawback is having to re-enable them for every app, but at least it works.

It’s probably the penultimate line on this page assistance:Accessibility Permission Problem [Keyboard Maestro Wiki]

1 Like

Yes it is : tccutil reset Accessibility