Can't Open Obsidian Links with Keyboard Maestro

Hi all

i have tried to open obsidian links via Keyboard Maestro like i do with many other apps (Devonthink,Omnifocus etc) yet i keep getting an error. is there something special regarding the obsidian URL's?

here is an example link to a specific note

obsidian://open?vault=Food&file=_%F0%9F%A7%ADMOC%2FCOOK

and how i try to launch it

yet it never works

any clue?
thx all

Z

An Obsidian link to an Obsidian outline in my Documents folder with Default Application worked as expected. I copied the link to the clipboard in Obsidian and pasted in into the Open URL field in Keyboard Maestro v9. Format is the same as yours. So I have no idea why yours isn't working.

ha thx @mrpasini

so bizarre, it dosent seem to work on my machine

to be clear this is what i do

i copy a link to a specific obsidian markdown file

image

and get the link

obsidian://open?vault=Food&file=cookingQ%2FThe%20Egyptian%20%22Mac%20and%20Cheese%22%20Everyone%20Will%20Love

then in Keyboard Maestro i paste it into the open URL macro with the with default application

when i try to launch the macro i get an error (this is from the log):

2021-10-11 08:47:04 Open URL failed with invalid URL “obsidian://open?vault=Food&file=cookingQ%2FThe%20Egyptian%20%22Mac%20and%20Cheese%22%20Everyone%20Will%20Love” In macro “G:Cook MOC” (while executing Open URL “obsidian://open?vault=Food&file=cookingQ%2FThe%20Egyptian%20%22Mac%20and%20Cheese%22%20Everyone%20Will%20Love”).

to be clear if i paste this in drafts and open the link it works well

is this a text encoding issue?

thx a lot!

Z

KM is probably getting tripped up on the percentage signs, since it also uses them for token syntax. What happens if you set the Open URL action to process nothing?

If that doesn't work, you can also try setting the URL to a variable and opening it that way (make sure the Open URL action processes text normally again first):

2 Likes

Ha! it was the processing indeed!

thx so much @gglick for helping with that!!

best

Z

1 Like

Yep, that's what I did, too. My link looks a little different:

obsidian://open?vault=Obsidian%20Notes&file=Nessuno%20Outline

And I don't see that orange warning on the URL that your screen shot shows. Both URLs are encoded. From the error message, yours seems to go beyond a reference to a file, though. You might truncate that to see if it helps.

FWIW, I have Process Normally selected (the default).