Can't trigger Mission Control

Super weird problem. I created a macro that sends the keystroke for Mission Control. When I press it, I just get a bad-key beep. I swear this used to work.

What am I doing wrong?

KM 8 on Mojave, if that means anything.

@iNik I was having a similar problem [I'm running Mojave 10.14.6, and KM version 9.0.4.].

This is how I got it to work :

  • Search for the "Execute an AppleScript" action in KM and add it to wherever you need it in the KM macro editor.

  • Paste the following script into the input field for the code, uncomment whichever key code line maps to your type of Mission Control shortcut, and you should be good to go.

    tell application "System Events"
        # key code 99 --F3 shortcut
        # key code {126} using {control down} --ctrl-up arrow shortcut
    end tell

"key code 99" is the key code for F3, the default Mission Control mapping. ctrl-up arrow is what I currently have MC mapped to. I'm posting that line as well since it was a pain in the ass for me to figure out and I figured I'd save someone else the trouble. I basically modified answers from this Stack Overflow post.

I tried it (with MC set to ⌃⇡) and got the same beep.


I then disabled KM’s Full Disk Access (System Preferences > Security & Privacy > Privacy), quit KM, reenabled Full Disk Access, relaunched KM.

Now the macro run without beep. But MC still did not launch.

I changed then MC’s shortcut to something without arrow (⌃⌥⇧⌘7), changed the KM action accordingly, and now it works.


Though the issue here concerns the MC main shortcut (and not the sub-shortcuts for moving spaces), I suspect this is basically the same issue @peternlewis confirmed here:

Unfortunately I noticed later that also non-arrow system shortcuts for MC commands seem to stop working randomly (independent of KM).

1 Like