Can't trigger system shortcuts


#1

I had a macro that contains an action to type the keystroke "Ctr + Arrow Left/Right" which triggers a system-preferences shortcut to moves one space left/right.

Always worked fine, but suddenly this does not seem to work anymore. I checked and none of the system shortcuts can be triggered like this anymore it seems.

Anyone got an idea why this is?

Thanks for your help
regards Julian


#2

This is a known Mojave issue/feature. Not expecting any change from Apple.
Workaround: Change the shortcut used in System Preferences.


#3

I have created this one, it keeps moving the window until you left the buttons go. I use it all the time. I will put it in the macro list, just in case you want to download it.


#4

Here you are...


#5

Hey Thanks for your help on this.
I found that executing the following Applescript instead of the keystroke seems to work for me.

tell application "System Events" to key code 123 using { control down }

I also tried changing the shortcut as you suggested but that somehow then also triggered mission ( / the fn key ), which was quiet odd.