Can't use `hub fork` command in KM and can't debug why

I have a macro I made:


g: fork repo to ~:dev:forks.kmmacros (41.0 KB)

This macro fails to do one part, the hub fork command. I have downloaded hub on my system.

And I have put contents of my $PATH into KM PATH variable like so:


However this doesn't work still. The hub fork should fork the repository but when I run the action it gives me back this error message: username: password for  (never stored): Error forking repository: Unauthorized (HTTP 401)
Requires authentication

If I run the same hub fork command in my Terminal however, it works perfectly and does the fork.

How can I make KM see my Git or Hub config?

Compare the environment in the Terminal with the environment in Keyboard Maestro and look for environment variables that affect git.

Basically, run the command env in Terminal and in an Execute Shell action, and compare the results.

The PATH is only one environment variable that can affect your shell processing - there are many others - indeed that is the primary purpose of environment variables.

Hey Nikita,

See this post: