Case affects action - not working in Sierra

KM 7.3.1 here, and Sierra 10.12.3

I use KM mainly to insert text by typing something when a string is typed. For example, when I type the string "xx " (2 letters ‘x’ and a space), KM will then simulates 3 deletes b4 executing, and then type the word “exercice” (with no commas).

Not sure when it started, but the “case affects action” doesn’t work anymore. Previously, I could type "xx " and KM would type “exercice”, and "Xx " would type “Exercice” (with 1st letter in uppercase). Well, this doesn’t work anymore, no matter options I check.
I tried everything, but the “case affects action” thing seems to be gone.
Any thoughts?

It works here without problems. (Also KM 7.3.1, OS 10.12.3)

xx → exercise
Xx → Exercise

Sorry, maybe I wasn’t clear enough: the “case affects actions” is still there in KM, exactly where you show it, on the right of the typed string field.

But it has no effect on the case of the final typed text. Not for me.

I also checked the Security/Privacy tab on System Preferences, and KM is correctly given accessibility privileges to control my computer (both the app and the engine). No result.

All of it always worked great before (before updating to 10.12.3, i think)

I understood you correctly. But what I tried to say is, it does work here; for each of xx, Xx and XX it expands exactly as shown in my post.

Maybe you have defined the same trigger in another app (Typinator, TextExpander, …)?

Here is my test macro: _[test] Case Affects Action.kmmacros (1.6 KB)

Check if it works for you. Maybe your macro is corrupted somehow.

Thanks, Tom!

I tried it, and discovered that the macros works…, but not in all apps!.
Now, does not work only (so far) in my virtual (Parallels) machine, but works in the Mac host side. That’s a discovery!

I use a lot Microsoft Office with Windows7 for work reasons. So, it’s probably to do with Parallels Desktop (they updated last week or so), because KM has always worked great, even in my virtual machines.

I’ll be looking at PD updates, and check this macro issue. Thanks a lot for your great support! Kudos to KM, a great, great Mac util!

I guess, the virtual machine takes over the keyboard input, so that KM doesn’t see the keystrokes, or does not see them properly. I’m surprised that it worked at all in the past.

Have you tried it with other text-expanding Apps (Typinator, TextExpander, …)?

But there’s a great Windows macro util, called Autohotkey, which I’ll give a try. I’ll keep KM in the Mac OS.
Thank anyway!