"Case must match" not doing as supposed to

My macro is intended to fire once a user types in ‘qc’ (two characters, one lowercase q followed by one lowercase c). It is NOT (!) supposed to fire if I should enter (uppercase) QC.

This is why I did select ‘case must match’ when defining the macro. However, to my amazement, Keyboard Maestro will still fire the macro regardless if I type qc, or QC.

Out of curiosity, I made a test. I told KM to fire the macro once I type in QC, and again, I selected ‘case must match’. Now everything works as it should, ie ‘QC’ does fire the macro, while ‘qc’ does not.

Can it be that this is buggy, or in other words, can it be that the guys at Stairway Software have confused ‘case must match’ with ‘case must match if uppercase’?

Thanks, Michael

Hey Michael,

I just replicated your macro and I did not experience a similar glitch.

Could you possibly have used case affects actions instead of case must match?

-Chris

Hi Chris,

thanks for responding, but no, I am sure that did not confuse these two settings.

Just to make sure that I got you right. You did set up a macro to fire every time the user types ‘qc’. Then please tell me explicitly what happens when you type ‘qc’, and what happens when you type ‘QC’.

Because for me, KM fires in BOTH cases, e.g. regardless whether ‘case must match’ is selected or not.

Thank you.

Hey Michael,

qc emplaces the text. QC does nothing.

Generic-Test 01.kmmacros (1.7 KB)

Are you using an English keyboard layout or something else?

-Chris

Funny thing. I have the same settings, but I am getting a different result, repeatedly.

Well, I am using a German keyboard, since I am located in Germany.
Could that make the difference, perhaps?

But if so, what can I do? :confused:

Hey Michael,

That could be it.

Export your macro.

If you can make a short movie of the misbehavior. QT Player will let you record the screen if you don’t have a dedicated utility.

Write up a bug-report for Peter and send it and the macro to the Keyboard Maestro support address.

https://www.keyboardmaestro.com/documentation/7/support.html

Put the movie in DropBox or another download service and include the URL in the bug-report.

If it’s a bug Peter will squash it.

-Chris

Check your System Preferences, Keyboard preferences, Text preferences - do you have a duplicate of the expansion here (perhaps synced over from an iPhone?)?

Make sure the macro is actually running - select All Macros and sort by Macro Execution. Trigger some other macro and watch it come to the top. Type “QC” and see if the macro in question comes to the top or not.

Chris, Peter,

I found it myself! In System Preferences, on the Mac, you can define Keyboard Shortcuts. These shortcuts are independent of Keyboard Maestro’s, though.

When I recently defined some keyboard shortcuts on my iPhone, I did not expect them to appear on my iMac as well – but in fact, they did! So what I ended up was: When I pressed QC (uppercase), then Keyboard Maestro did the expansion of the shortcut, and when I pressed qc (lowercase), OSX did.

Now that I have deleted the ‘regular’ (non-Keyboars Maestro) Shortcut on my iMac, everything’s fine. Looks like I’ll have to come up with another solution for my iPhone, but that’s another story… :smile:

Perhaps this is helpful for you to know. Thanks for all your assistance!

Michael