"Click at Found Image" No Longer Working

Looking for some troubleshooting ideas. Found a thread from about two months ago in which an OSX update apparently de-activated permissions in System Preferences for screen recording. I un-checked and re-checked all KM instances in System Preferences, even though none of mine were un-checked.

Clicking "Go" does not move the pointer anymore (it used to, though).

I'm pretty sure this is something simple, but I can't seem to figure out what it is.

For tests, I'm rolling with:

scr 2021-09-18 at 12.26.12 PM

Slider set to about 1/4 to the left. I tried Best, Unique and Topmost, and pretty much every option for screen/area except area itself. I'm testing on a 15" laptop without a monitor connected.

The fact the pointer doesn't move, suggests to me it's some sort of issue in the System Preferences.

I suppose I could try running Onyx but that app seems unnecessary these days.

Any thoughts?

Edit: since tried fuzziness at 1/4 left, dead-center, and 1/4 right. Also ran Onyx just for the heck of it--hoping it might fix some sort of permissions/accessibility issue. No dice.

I’m not at my computer to test anything but clicking go won’t move the mouse unless the image is actually found if I’m not mistaken.

Have you tried testing with different images to rule out issues with that particular image?

Permissions issues could still be the culprit…have you tried everything in this wiki?

1 Like

Thanks for posting this, because I was having problems also.

It turned out that for me, "Keyboard Maestro Engine" wasn't even listed in the "Screen Recording" Privacy permissions listbox. In the KM Editor, I selected File>Quit Engine, then restarted the engine, and the OS asked me if I wanted to give it permission to record the screen. I did that, then stopped and restarted the engine, and now I'm fine.

Don't know if that'll help you or not.

Hi Dan,
An odd observation: I am successful running a macro to take a screenshot (not by typing a keystroke, but rather, by running KM's screen-capture macro).

After reading your post, I quit the engine, re-visited the Screen Recording listbox (in System Preferences, Privacy) and instead of un-checking/re-checking, this time I hit the minus sign and got rid of the KM stuff. Then re-launched, tried taking a screenshot, got the permission-denied prompt to go into System Preferences, then checked that box (KM had re-appeared), and successfully ran a macro to take a screenshot.

My pointer is still paralyzed though. So peculiar! I contemplated re-installing KM itself, but the thought of not having my pallets and macros automatically reappear, is a terrifying one. I haven't even researched this process---I assume all these things would indeed reappear without issue, but I rather not go this route unless I feel I have to.

Some stupid app or something on my machine must be causing this. It must be some sort of permissions issue somewhere. Ugh!

I was able to use the screenshot action, even before I fixed the problem with Found Image. Not sure why.

Thanks Dan. This is helpful. Still testing.

  • Back up your your Keyboard Maestro Folder at:

    • ~/Library/Application Support/Keyboard Maestro
  • Download the Keyboard Maestro application anew:

  • Remove the Keyboard Maestro application.

    • This does NOT affect the KM application support folder.
  • Manually drag the Keyboard Maestro app to where you want it.

    • The default location is /Applications/Keyboard Maestro.app
  • Fire it up.


Thank you for this, Chris. Gave it a go. Still dead in the water. The only thing I can think of that changed a couple months ago, was turning Apple's encryption back on, for my bootable (internal) drive. I can't for the life of me remember why I turned this off. I think I did so very early in the year, but why I did so, I can't remember. :confused:

I can't see how this would the functionality however. Keeping it simple, I think I'll know it's about to work, or actually working, after the pointer hops when "Go" is clicked within the Click on Found Image macro in the editor.

I presume this question will reveal myself as a non-computer scientist or IT person in general (both of which, are true :grinning_face_with_smiling_eyes:): am I correct that display hardware has nothing to do with the functionality of this macro?

Edit: I'm testing bare-bones: just a 15" 2015 MBP (15"). MacOS 11.5.2 and KM 9.2.

I did get the Go button within the Click on Found Image macro to respond, but the behavior is a demonic one. (It's much too early for a Halloween prank!)

It only wants to look, blindly, way up high---no matter where the fuzziness slider is, or what the In setting is put on. So strange!


Screen resolution and the resolution of the screenshot you're trying to find must be in sync.

Do not run Find Image macros from the Keyboard Maestro Editor, the image in the find image action can get in the way.

Hide the Keyboard Maestro Editor, and run your macro with a keyboard shortcut.

That little question mark likely doesn't have enough contrast to be uniquely found.

Play around with something bigger that has more contrast.


Tried. No dice. When the KM is used instead (and, obviously, just for testing purposes), at least I can see those orange or green squares appear---which only appear up in the header of the editor itself---which is really weird behavior. (I've used this macro in the past---this is behavior us unusual.)

Something dawned on me--er, two things actually:

  1. The previous time I used the macro, I ran it on a 2013 13" MacBook Pro. I'm trying to run it presently on a 2015 15" MBP, which uses a very peculiar dual graphics card design. One part of the graphics hardware is inside the Intel i7 chip---the other part, is in a standalone chip somewhere else on the motherboard. Could this wonky hybrid be the culprit?
  2. I did, fairly recently, turn Apple's hard-drive encryption back on--as I think I mentioned above. I wonder if this isn't getting in the way? (Seriously considering doing a backup to Carbon Copy Cloner, turning FileVault back to OFF to test if this is impacting anything.)

I really appreciate your thoughts on this btw!

Tried various settings with your profile graphic as the target.

If you haven't retaken the image to find, then that is quite likely a problem.


I did. Sorry, I was editing to point this out as you posted.

Have you turned on Reduce Transparency?

All the overlapping transparent elements in Big Sur make it hard to get a consistent image in various places.



Nope. Only shake mouse to locate is checked (which is in its own tab now, in the current version of Big Sur).

Give it a try.

Very sorry--I didn't think through your proposed idea. No dice. Tried the high contrast one too, using the big blue Reply button we see here in Discourse, as target. Slid the fizziness slider to 1/4 left, dead-center and 1/4 right, and focus to top-most window, mode from unique to best to bottom to left-most----no dice.

I keep hoping this is something simple--not the result of an OSX update.

Thanks again for all the help and ideas. I do appreciate this very much!

You're not the only Big Sur user who's had this problem...

Most have been able to fix things by fiddling with their accessibility settings, but not everyone.

How are you capturing the images your using for comparison?


How are you capturing the images your using for comparison?

CMD+4, save to desktop as JPG, then (because I don't know a better way), I just open up the file in Preview, then do a CMD+C--same general process I use to change icons in KM pallets.

Don't save the file.

Hold down the Control key when you take the screenshot, and that will copy it to the clipboard.

Then paste the image into the image-well in the Keyboard Maestro action.


1 Like