Click Safari Link works with "Try" but not when running

I've been trying to get KM to click on the the "Current Statement" link on the American Express website which will then download the the current statement to my Downloads folder. I tried getting the position with %FoundImage%, and while the mouse will go there, I can't get it to click the link.

So I tried the Click Safari link. When I "inspect" the element it looks like this:

I used the XPath, but as I got the HTML, Selector Path and XPath. Here they are in case that would be helpful:

Current Statement (Apr 20 - May 20)

Current Statement (Apr 20 - May 20)

Selector Path
#root > div:nth-child(1) > div > div > div > div > div:nth-child(5) > div > div.container.pad-1-tb > div > div > div > div > div.col-md-9 > div > div > div:nth-child(1) > div > section > div.row.pad-2-l.false > a > p > span.pad-1-l > span


As I said above I used the XPath in my Click link action. When I run the macro I don't get any error message, but it also doesn't work either. What's weird is that if I then click that action and then "Try" it does work. I thought it might be a timing issue so I put a 10 second delay in before I tried clicking the link, but that still didn't help.

I don't know who to write scripts, so if that is the preferred solution any help would be appreciated.