Clipboard changed trigger not working when copying text in Parallels Desktop

I want to display the number of characters of text in my clipboard whenever I copy something. It works splendidly, except when I copy text inside Parallels Desktop, running Windows 11 Pro. The copied text is put in the system clipboard, but the change doesn't register in KM to trigger the macro. I guess this is because Parallels is its own weird system, and there is probably no fix. Still, I wonder if anyone else has this issue?

Your question is completely legitimate. But not everyone here will have Parallels. So I tried using ChatGPT to figure out what your problem was and got the following result.

Copying and pasting text between Parallels for Windows and macOS should work seamlessly, but if you're experiencing issues, it might be due to a few common reasons:

  1. Parallels Tools Not Installed or Outdated: Ensure that Parallels Tools are installed and up-to-date. Parallels Tools are essential for integrating the guest OS (Windows) with the host OS (macOS).

  2. Shared Clipboard Not Enabled: Check if the shared clipboard feature is enabled in Parallels settings. You can find this in the Parallels Desktop configuration under Options > Sharing > Share Mac clipboard.

  3. Temporary Glitch: Sometimes, the clipboard sharing may fail due to a temporary glitch. Restarting both the Windows virtual machine and Parallels Desktop might resolve the issue.

  4. Software Conflicts: Other clipboard management software on either Windows or macOS could interfere with Parallels' clipboard sharing feature. Try disabling or uninstalling any third-party clipboard managers to see if that resolves the issue.

  5. Resource Constraints: If either the macOS or Windows environment is under heavy load, clipboard operations might not work properly. Ensure that both systems have adequate resources.

If none of these solutions work, you may want to check the Parallels support forums or contact their customer support for more specific troubleshooting steps.

Thanks for trying, but ChatGPT is not helpful. As I wrote, the system clipboard is properly filled from Parallels/Windows, it's just that the clipboard trigger doesn't fire.

I think it's a wonky interplay between KM and Parallels. When I'm in Parallels and run a KM macro that just contains the "Copy" action, the selection is not added to the system clipboard.

Yes I did read that, but that was the best research I could do for you anyway. I thought maybe something there might ring a bell, or be worth testing.

Can you post your macro, or at least the appropriate parts of it? Also your OS and version of Parallels, in the hope that someone can replicate the issue.

And check that that particular macro group isn't disabled when Parallels is frontmost -- that's caught me out more than once!

I'm a bit behind, but the trigger works fine with macOS 10.14.6 and Parallels 15/Windows 10.

Here is my super simple test macro. On my system (macOS Sonoma 14.5, Parallels 19/Win 11) it doesn't get triggered when I copy something from within Windows (no matter how I do it). The Clipboard History immediately shows the new entry from Windows, but the macro won't get triggered, no matter how I do the copying (right-click, keyboard shortcut, application menu…).

Parallels copy trigger test.kmmacros (2.6 KB)

How about the setting for the Group this macro is in? If you've set it to be active only for certain apps, what happens if you add TextEdit and do the copy there?

I've got the Parallels update licence, I'm just waiting on a chance to upgrade to Sonoma (ironically, what stopped me doing that today is a long-running being done my Windows VM!) so, hopefully, I'll be able to replicate your setup on Wednesday.

Same set up here and I can confirm your findings, Stefan.

I tried with VMware Fusion
Player Version 13.5.2 (23775688)
Windows 10 Pro, 64-bit
Here the macro works, as soon as I move the mouse pointer outside the VM, over the menu bar:

Here's an idea: install AutoHotkey under Windows and let it perform an action when the clipboard changes and that can be triggered by Keyboard Maestro. E.g. by creating a file in a folder that is being watched by Keyboard Maestro, etc.

I fear that may be wasting bandwidth.

1 Like

I presume that's just a sarcastic joke to make us laugh. There's nothing in the Code of Conduct that says we can't use ChatGPT. I used it because nobody else was helping this poster, and I didn't have Parallels so I couldn't test for a solution myself.

I wouldn't object if a moderator deleted this post of mine, and yours.