Clipboard History Switcher and MS Word Problem

Hi everyone, I just really started using KM and am really loving it! However, I've run into one problem with the Clipboard History Switcher (CHS) with MS Word:

Text copied from MS Word is unable to be copied in the KM CHS. That is, whenever I copy multiple selections of text from MS Word, copying previously copied text in the KM CHS does not copy it. It is only the latest thing that was copied from MS Word. I'm not sure if I'm being clear, so by way of example: If I copy the each of the following lines separately in MS Word...

Test 1
Test 2
Test 3

... When I copy "Test 1" from the KM CHS it only pastes "Test 3" (the last thing that was copied). This only happens in Word as far as I can tell (works as expected in Sublime Text).

This solution seems to be similar to the one found here: Reproducible bug w/Typinator + clipboard history switcher

But that thread is four years old and I don't want to paste anything in Terminal that might cause other problems.

Have any of you here run into this problem and found a solution?

Any help will sure be appreciated!



Hey @peternlewis,

I can confirm this happens with Microsoft Word 16.16.27 on Mojave.

  • IF I use the toolbar icon in the clipboard history viewer to copy the text.

On the other hand – if I use the contextual menu to “set clipboard to” I am able to paste the correct item.

If I simple select the item I want and use the paste toolbar icon or hit Return then it works as expected.


I can confirm this happens with Microsoft Word 16.16.27 on Mojave.

Thanks for confirming this @ccstone !

@peternlewis I am running MS Word 16.55 on Mac OS 12.0.1.

However, when I use Return (didn't know that will work), it still pastes the last thing that was copied.


  • What version of Keyboard Maestro?
  • What version of macOS?
  • What version of Microsoft Word?

Hi @peternlewis here are the versions:

  • What version of Keyboard Maestro?


  • What version of macOS?


  • What version of Microsoft Word?


Hey Darryl,

I just retested here, and things still work for me as described with:

  • macOS 10.14.6
  • Keyboard Maestro 10.0.1
  • Microsoft Word 16.16.27

Unfortunately I can't test with Monterey.

@tjluoma – do you have Microsoft Word?


I do have Microsoft Word.

How can I help?

Open Preferences, click on the Excluded pane, and check to see whether Word is excluded from the clipboard history.

Would you mind testing this problem on Monterey?

Darryl and I get different results with different versions of macOS and Word, so I'd like to enlarge the sample.


I'm not sure that I'm following, but here's what I tried:

First I created a Word document which has these lines in it:

This is the first sentence 
This is the second sentence
This is the third sentence

Then I selected each sentence and copied it, using ⌘C or Edit » Copy or Right Click » Copy.

They each appear in the menu bar item for Keyboard Maestro's pasteboard history, and selecting them from there pastes the right one each time.

Is there another way to paste from the clipboard history? If so, I didn't try that, but would be willing to.

Word 16.55
Keyboard Maestro 10.0.1
macOS version 12.0.1 (21A559)

1 Like



Activate Clipboard History Switcher.kmmacros (6.7 KB)
Keyboard Maestro Export

@thoffman666, thanks for the suggestion. I just tried the using the Excluded pane, but still experience the same behavior. [Edit: I edited this post because I realized that I mixed up 1Password and Word, but have tried the original suggestion.]

@tjluomal thanks for testing on your machine. We are both running the same versions for Word and MacOS, however, I am still on KM 9.2. Perhaps it's time to update to version 10.

Just to clarify, ADDING Word to the Excluded page will CAUSE the problem you're describing, so you want to be sure that Word is NOT on the excluded list. But if something else is causing the problem, then removing Word from the Excluded list will still not fix it.

1 Like

@thoffman666 that's for the clarification! Word has not been included in the Exclusion pane as I have been experiencing this behavior (there is nothing in the Exclusion pane).

I just tried this in Big Sur with Word 16.47 and Keyboard Maestro 10.x and have no issues.

If you are in 9.x, then the defaults write line from the mentioned thread may well be needed, since it would be included by default in version 10.

1 Like

@peternlewis thank you for confirming and testing. I actually just upgraded to version 10 and it's working properly! Thanks everyone for your help and time!