Clipboard History Switcher missing in action

The window with the clipboard history has disappeared on my 10.13.1 Mac running 8.0.4.

Whether I use my hot key or just test the action directly from KM, the KM icon blinks as if it is popping up the window for the clipboard history but it is no where to be found.

The named clipboard window pops up just fine.

The basic history functionality works if I know which history one to paste but when I need to see which one I want then I’m in trouble.

Any ideas?

No solution here but I can confirm the problem. I’ve been wrestling with it for a while.

Peter Lewis wasn’t able to duplicate it but pointed out you can quit the Keyboard Maestro engine and relaunch it to get the window to display again.

The log revealed nothing helpful, just a “Caught Unknown Error while doing action in HExecuteActionListEntry::HandleDoAction().”

Peter suggested creating a macro to delete the past clipboard entry and to use it until you get the window back. The one time I tried that, the macro wasn’t able to delete anything on the clipboard (although it worked fine when the window was working).

So, as I said, no solution but at least you aren’t crazy.

Good that I’m not crazy. Bad no resolution.

Quitting KM doesn’t help.

Wondered if the window is appearing off screen somewhere. Am using mission control’s virtual desktop. Does the window remember its location? If so can I delete/modify the preference file to pull it back if this is the issue?


James R Ehrler

Check the Engine.log file to see if any issue is reported. If it is the same issue as @mrpasini then there should be a message in the log file. If not, then it might be something completely different.

It’s possible, but the window should put itself back on the screen any time it is opened off the screen.

Here is what it reports…looks like the same as @mrpasini:

2017-11-08 19:52:32 Execute macro “Activate Clipboard History Switcher” from trigger The Hot Key ⌥⌘V is pressed
2017-11-08 19:52:33 Caught Unknown Error while doing action in HExecuteActionListEntry::HandleDoAction()


James R. Ehrler

Yep, looks like the same issue. Unfortunately, I have not been able to duplicate it or find out where the exception is happening. My guess is it is related to what or how or where you have copied something. The only way forward I can see is to add a whole bunch of debugging to track how far it gets before throwing the exception.

Is there a way to clear the history to see if that at least brings it back for now?

Or could I send you the history file for you to do your magic?

Quitting and relaunching the Keyboard Maestro Engine should resolve it (if you don’t save your clipboard history to disk).

If it does not, then we can perhaps use that to find the offending entry, though it’s a bit tedious:

  1. Quit and relaunch the Keyboard Maestro Engine, verify if the problem recurs.
  2. Duplicate the Keyboard Maestro Clipboard History.plist (in Keyboard Maestro Preferences folder)
  3. Run the action Delete Current Clipboard ten times.
  4. Quit and relaunch the Keyboard Maestro Engine, verify if the problem recurs.
  5. If the problem continues, go back to step 2.
  6. Otherwise, quit the Keyboard Maestro Engine, restore the Keyboard Maestro Clipboard History.plist from the last duplicated one, and relaunch the Keyboard Maestro Engine, verify if the problem recurs, which it should.
  7. Repeat the steps, but deleting 1 clipboard each time until you get to the point where deleting one clipboard will make it work.
  8. Send me ( the last broken Keyboard Maestro Clipboard History.plist file and I will take a look. That may give us a clue.

OK, quit KM, dragged the Keyboard Maestro Clipboard History.plist to the desktop and then relaunched KM.

The Clipboard History Switcher is now functioning again. Yay!

I kept the old plist file if it would be helpful for you to look at it.

Was too quick with self help and moved the offending history plist file before I saw your post. Kept it if you want me to send it.

OK, used the plist editor to delete almost all the clipboard entries except the one that causes the History Switcher window to not appear plus two more items. Once I delete the offending entry the window pops up so the problem is in one of the 3 entries in the plist file I emailed you.

1 Like

In my case, I positioned the window both on my main screen and on a second monitor. It always appeared where I last left it. And the problem occurred on both screens.

Found and fixed for the next version. Thanks.