Create Folder Structure on Network Drive

Hello Keyboard Maestros!

I've created a macro for creating a folder structure based on a user prompt and the date, and it works locally but won't function on a network drive. Also, when I run it locally it's adding a "?" to the end of the top folder that it creates first.

For context, I used Zabobon's macro here as a starting point: Create folder

And these are my macros below.

Basically I have a main macro which prompts for text input, a checkbox selection that will subtract one day from the date for certain uses, then finally it grabs the date and sets them as variables. The macro then runs an IF statement and will run either of the two sub macros that create subfolders depending on the checkbox selection.

When I run it on the MacHD, the topmost folder has a question mark appended to the name, but all the subfolders work fine.

If I run it on a network drive (in this case an Avid Nexis), the macro does not run at all.

Any help would be greatly appreciated, I'm not sure where this one is falling apart.


NRDN - Create Dailies Folder Structure Tomorrow's prep.kmmacros (5.8 KB)
NRDN - Create Dailies Folder Structure.kmmacros (5.5 KB)

Screenshot 2024-01-30 at 6.00.51 pm

This is the dreaded invisible return character...

In this Action you have an extra line that can't be seen until you select it. If you select and delete that extra line, you won't get the "?" as the end of the folder name.

A clue is in the preview at the bottom of the Action where the return symbol is shown at the end of the name.

So, Keyboard Maestro is trying to make a folder with a return character at the end of its name and as that can't be done in the Finder it gets replaced with a "?".

Ah! Thank you Zabobon, appreciate your answer on the original question too. Always clear and to the point!

Do you happen to know about the network drive issue? Is there any reason you can see that it wouldn't work there?

Thanks again

To troubleshoot this I'd make a very simple test macro with one action that makes a new folder at a place navigated to in Finder. The below works for me for an external drive on my network.

Not sure what I changed but it's now working. Thanks for your help!