Disappearing Macros

Maybe this is pilot error, but I’m having trouble understanding how it happened…

About a week ago, I made four macros. One pair launched and quit App X when USB device X was connected or discconected, the other doing the same with App Y and USB device Y. They worked perfectly.

I do not remember making any adjustments to them after setting them up. I used them daily, and was very happy to have them working. Today, I plugged in USB device X, and nothing happened. Same thing with USB device Y. I went looking for the macros in KM, but they were gone.

I solved this by Reverting Macros back one day. I have no recollection of adjusting or deleting anything in KM in the last week. Any ideas what’s going on? How I can avoid a repeat performance?


Other than syncing, no much will affect your macros except you.

It’s not overly hard to delete macros or macro groups, and run-away macros can do it fairly easily too, so perhaps an errant macro deleted the macros.

Other than that, it is hard to say.

You might peek in the Engine.log for Keyboard Maestro, accessible from the Editor’s Help menu (Open Logs Folder). Hunt down the date and see what macros were executed.