Display Of Macro Group Palette Seems To Disable Macro Groups

I admit I'm not confident of my understanding and limited use of macro palettes! So, this is likely a simple "DUH" issue, but any suggestions would be appreciated. I am running Sierra 10.12.6 and KM 8.0.3 on a MacBook Pro with TouchBar.

For some time, I thought without issue, I've used a couple of macros to show/hide palettes (first suggested by JMichaelTX) as reminders of my available KM macros. However, now it appears that after invoking the macro to show/hide macros from two groups, neither of the group's macros work as though the groups have been disabled. At first I thought the engine had stopped until I noticed that macros from my other groups still work! After invoking the show/hide TextExpander Group macros shown by the screenshot below, no problem arises. However, the show/hide PantherMac Groups I & II, stops these groups and the TextExpander group macros from working! The Clipboards and Text Manipulation groups macros all still work as expected. Currently, to resolve the issue, I quit and then launch the engine to get all macros working again. I've provided some screenshots to perhaps show what I might be doing to cause my problem.


KM Macro To Show TextExpander Palette Screenshot - NO APPARENT PROBLEM CAUSED BY THIS MACRO

KM Macro To Show PantherMac Groups I & II Palettes Screenshot - MACROS NO LONGER WORK AFTER INVOKING THIS MACRO

All macros groups are defined as:

  • Available in all applications
  • Available in all windows
  • Always activated

To better help you, please upload your macro that is causing the problem.

Keyboard Maestro 8.0.3 “Keyboard Maestro Display PantherMac Group Macros Palette” Macro

Keyboard Maestro Display PantherMac Group Macros Palette.kmmacros (2.3 KB)

Keyboard Maestro 8.0.3 “Keyboard Maestro Display TextExpander Group Macros Palette” Macro

Keyboard Maestro Display TextExpander Group Macros Palette.kmmacros (2.0 KB)


Are you able to identify an issue?

Anyone see an issue which should cause the macro groups to be disabled?

I’m afraid I can’t tell what the issue may be, but I can ask a couple of questions that may possibly help with troubleshooting:

  1. When the macro groups become disabled, i.e. grayed out and inactive while still technically remaining enabled like you show in your screenshot, does explicitly disabling and re-enabling them get them working again, or is restarting the whole KM engine the only thing you’ve found that works?

  2. Why do you have a "Set Trigger to %TriggerValue%" action before each show/hide macro group action? While I admittedly don’t see how leaving such an action in could result in the behavior you describe, I also don’t see why it’s necessary, since it seems like you’re triggering all of these macros the same way each time (i.e. through the palette). Just for the hell of it, does anything change if you disable or remove that action so you’re just left with the show/hide macro group actions?

Yes, because you cannot disable or alter the settings of the Global Macro Group.

Generally, Macro Groups that show a palette will only be active while the palette is displayed. So once you show the palette, when the palette is hidden, the macro group will be inactive.

If you want the macro group to be active always, even when the palette is hidden, then as of version 8, you can specify that it the macro group

1 Like

Thank you for responding to my request for assistance!

  1. The macro groups never appear grayed out without actually disabling the group. Disabling & re-enabling the group didn’t resolve the issue. So far, only stoping and relaunching the engine has resolved the issue.

  2. Regarding the initial action, its an action I put in all my macros. Admittedly, its not used here, but its a habit statement I enter for a variable I save and can check for how any macro is invoked. As you note, it shouldn’t have any impact or relevance to my issue. However, because I had no clue as to what else to debug for this issue, I removed it and the problem was still observed.

I may need assistance to get Peter’s suggested approach to deliver the response I desire. Since I have the macros broken into two groups due to the large number of hotkey macros, I want both palettes to show using the same hotkey as shown in my previous post. When I tried what Peter suggested, I get a conflict palette instead of both macro groups to show since I’ve used the same hotkey. Further suggestions on how this approach can deliver what I want would be appreciated.

You're quite welcome. Hopefully this response will be more helpful than my last one :slightly_smiling_face:

I've tried replicating your setup with two macro groups of my own, and added an If Then Else action at the end to explicitly activate both groups if either one is inactive. Hopefully this solution will work for you:

If this alone doesn't do the trick, try also setting both PantherMac macro groups' activation options to the setting Peter showed above, "Always activated and shows/hides a palette when:" so that they look like this:

If you've tried these ideas and things still aren't working as you want, let me ask you about a potential workaround: what about putting all of the PantherMac macros into a single group and configuring that palette to use two or three columns? I can see from your screenshots that the two palettes already take up a considerable amount of screen space, so I don't think a palette with multiple columns would be that much of a change in terms of screen real-estate. Just something to consider if the above ideas don't work out (though of course, hopefully they will, and this alternative will prove to be entirely unnecessary :slightly_smiling_face:)

Activating or Deactivating a macro group is different to Enabling or Disabling it.

The former is a runtime, transient condition, only applicable to the Keyboard Maestro Engine. The latter is a semi-permanent condition, that shows in the editor, and is synced if macro syncing is on.

So you wont see any macro group grey out in the editor if you activate or deactivate it, or show or hide a palette.

Many thanks to gglick for the suggestion to use the multiple columns and Peter for the “Always activated and shows/hides a palette when:” setup. Works perfectly without failure or disabling of any macro groups!

1 Like

Glad your issue was finally resolved!