Emulate ClickPaste in macOS?

Anyone have any thoughts on how to emulate a similar effect to ClickPaste (GitHub - Collective-Software/ClickPaste: Windows 10 notification area app in C# that can paste clipboard contents as keystrokes to whatever location you click.) with Keyboard Maestro?

Personally I'd just like to be able to trigger typing the pasteboard when a key combo is pressed so that it will be simpler to "paste" text into virtual machines and remote access when the pasteboard is not shared with a Windows or Linux clipboard.

Have you tried this yet?

1 Like

Thank you. I think I was getting some strange issues from another program I was using to create a "super key" that was causing me not to see this work right. After fiddling with it for a bit it began to work as expected. The joys of Ventura...

One thing I have noticed @Frankb is that when using this is that certain characters are not properly escaped in some scenarios when triggered. For example, https://forum.keyboardmaestro.com/ becomes https://forum>keyboardmaestro>com? or https:/?forum>keyboardmaestro>com? seemingly randomly and with different operating systems (eg, either Windows or Ubuntu, Xubuntu, etc.).

I am not an expert at all, but I could imagine that this is not a KM problem, but one caused by the different operating systems. I'm sure others know more about this.

Are you sure it's the typing/pasting that causes the issue?

Have a look at the Filter action, which has processing options for URLs. They may be of help, depending on the type of errors you're dealing with.

@noisneil I was just thinking how it would be to have a macro that tries both (⌘+v) and if that doesn't work types the clipboard. That doesn't work. Do you have any idea?

Doesn't work as in "doesn't do anything"? I'm on holiday without a mac so can't really dig in unfortunately.

Exactly. But forget it, I wish you happy vacations :smiley:

1 Like

Is your macro in a global group?

No, for testing only in this app. I guess you have to tell KM to cancel the macro if ⌘+v works.

BUT, we stop now, you should enjoy your vacation.

The reason I bring this up is that the strange behavior occurs between disparate unrelated operating systems when pasting in. It pastes fine into any macOS app, but when I paste into a virtual machine connected through a Proxmox session in a browser, it seems to do this. I wonder if it is because it's typing "too fast" - but I don't see a way to slow down the "typing" into the app. I don't have any filter applied. If I apply a filter action and tell it to remove the style, it doesn't change any of the behavior (but that shouldn't change anyway since it is already plain text going in sans formatting).

You can slow down the typing speed using the Set Action Delay action.


Amazing, thank you. That was it @noisneil. By adding a 0.008 delay at the beginning I've now eliminated the superfluous chars.

1 Like