Enable Keyboard Maestro in accessibility

Hi All,

I'm trying to execute a screenshot macro, but it asks me to enable screen recording on my security and privacy screen recording but i can't add the Keyboard Maestro engine, i've already enabled Keyboard Maestro. I've tried quitting the engine and starting it, and enabling the macro but it doesn't appear in the list for me to click

Running Mac OS 10.15.1
Keyboard Maestro 9.0.4

its inside KM:
/Applications/Keyboard Maestro.app/Contents/MacOS/Keyboard Maestro Engine.app
so, you can
1-open Finder window, go to applications, then right click KM, 'show package contents' and navigate to the path I posted above.
2- now, open OSX System preferences, and when asked, drag the Keyboard Maestro Engine.app into the window.


thanks for your help

but in System Preferences >> Security & Privacy >> Privacy >> Screen Recording
i can't add the engine in, i can't drag anything in or there's no "plus" button to add the app

Only Keyboard Maestro itself needs to be listed and enabled in there (Apple’s security permissions are highly inconsistent in this regard).

My guess is the system is either confused, or has the wrong version of Keyboard Maestro enabled or some such nonsense. Try restarting. Try performing an action that requires Screen Capture (the Screen Capture action is a good bet). Hope that it prompts you to add it again.

Otherwise you can try resetting the permissions with the tccutil command:

tccutil reset ScreenCapture

or maybe

tccutil reset ScreenCapture com.stairways.keyboardmaestro

the first command seemed to have work

thanks a bunch!