Expansion not working in iTerm

I have added a macro to insert text into my terminal when I type a specific string.

The macro works fine when I type into any window, including this one I am typing this message into, but when I type it into my terminal it doesn’t expand. I have a couple of other text expansions, and they are exactly the same.

I am using a typed string trigger, and this triggers an Insert Text By Typing Action. I can’t specify the trigger here as typing it will expand. It just doesn’t do it in iTerm.

I’m running iTerm 2.0 Build 3.0.15, Keyboard Maestro 7.3.1, and I am using ZSH as my terminal shell.

How do I get the expansion to work inside iTerm

Almost as soon as I sent this, I found the answer. iTerm, by default, enables Secure Keyboard Entry (iTerm2->Secure Keyboard Entry (Cmd-Alt-S)). Disable this and everything works fine.

1 Like

If you select from the Keyboard Maestro Status Menu while this is happening, it should include a warning that Secure Input Mode is enabled.

1 Like