External HID to trigger mouse action in Fusion 360

I've tried (and searched) for a couple of days now, but I can't get this to work – I would love some help;
I have an external Midi controller/box that sends HID signals as well (I'm a quadriplegic so I can't use a keyboard, but I have a little bit of gross shoulder control so I can mash a couple of big keys, hence the stomp box style Input device), and navigation in CAD is proving to be a major hurdle. What I would like is to hit a button with my hand and have that interpreted as a middle mouse button hold so I can orbit around a model, then when I release the bottom it stops the action. Alternatively a toggle would work as well – press button once to activate the orbit, press button again to release it. Then similar actions for pan, zoom etc.
I've tried BTT, and it sends a signal through, but it proves to be a bit janky and won't release the action. I've looked it karabiner-elements but having to learn how to code/json is not really something I want to start. I'm hoping KM will be able to achieve this, but I'm not sure? If this is the wrong tool, just let me know and I can keep looking (advice for more appropriate tools would be appreciated as well...)
I would really appreciate it if someone could either help out, or point me in the right direction with some examples of how to do this? There is a bunch of other things I want to try and do, so I'm hoping with an example or two I'll be able to work it out after this...
Many thanks!

I just realized the picture wasn't complete. I use an iMac with the accessibility functions – pointer control which tracks my face and translates into cursor position, and facial gestures which gives me a left click, right click and drag functionality – and it works surprisingly well. These, coupled with the dictation/voice control allow me to use the computer relatively well, though quite slowly.
Sorry this wasn't clear from the initial post, I only realized how weird it sounded after re-reading it...:slight_smile:

Sorry to bump, but with no response I'm assuming that means this isn't the right way to approach the problem? It would be great if someone could point me in the right direction...